aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-12 22:53:50 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:41 +0000
commit4b88b53d01eb718f930a4aa36fbaec624726d57a (patch)
treea56419b8eefdf6a9640497817ab0a3092378f14e
parentcd590445c22e30c50e60c8001f2ced06dde7026b (diff)
downloadguix-4b88b53d01eb718f930a4aa36fbaec624726d57a.tar.gz
guix-4b88b53d01eb718f930a4aa36fbaec624726d57a.zip
gnu: go-google-golang-org-protobuf: Enable all tests
* gnu/packages/golang-build.scm (go-google-golang-org-protobuf) [arguments]: <#:phases>: Remove 'disable-failing-tests. Change-Id: Iaec1e3238765e20ce7caecf60cdae7bc236161fc
-rw-r--r--gnu/packages/golang-build.scm12
1 files changed, 0 insertions, 12 deletions
diff --git a/gnu/packages/golang-build.scm b/gnu/packages/golang-build.scm
index 75eaf61b9d..11978d8524 100644
--- a/gnu/packages/golang-build.scm
+++ b/gnu/packages/golang-build.scm
@@ -868,18 +868,6 @@ values.")
#:import-path "google.golang.org/protobuf"
#:phases
#~(modify-phases %standard-phases
- (add-after 'unpack 'disable-failing-tests
- (lambda* (#:key tests? unpack-path #:allow-other-keys)
- (with-directory-excursion (string-append "src/" unpack-path)
- (substitute* (find-files "." "\\_test.go$")
- ;; XXX Failing on i686-linux:
- ;; panic: unaligned 64-bit atomic operation
- (("TestDynamicTypesExtensionNotFound")
- "OffTestDynamicTypesExtensionNotFound")
- (("TestDynamicTypesFilesChangeAfterCreation")
- "OffTestDynamicTypesFilesChangeAfterCreation")
- (("TestDynamicTypesFindExtensionByNameOrNumber")
- "OffTestDynamicTypesFindExtensionByNameOrNumber")))))
;; XXX: Workaround for go-build-system's lack of Go modules
;; support.
(delete 'build)