aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-build.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/golang-build.scm')
-rw-r--r--gnu/packages/golang-build.scm12
1 files changed, 0 insertions, 12 deletions
diff --git a/gnu/packages/golang-build.scm b/gnu/packages/golang-build.scm
index 75eaf61b9d..11978d8524 100644
--- a/gnu/packages/golang-build.scm
+++ b/gnu/packages/golang-build.scm
@@ -868,18 +868,6 @@ values.")
#:import-path "google.golang.org/protobuf"
#:phases
#~(modify-phases %standard-phases
- (add-after 'unpack 'disable-failing-tests
- (lambda* (#:key tests? unpack-path #:allow-other-keys)
- (with-directory-excursion (string-append "src/" unpack-path)
- (substitute* (find-files "." "\\_test.go$")
- ;; XXX Failing on i686-linux:
- ;; panic: unaligned 64-bit atomic operation
- (("TestDynamicTypesExtensionNotFound")
- "OffTestDynamicTypesExtensionNotFound")
- (("TestDynamicTypesFilesChangeAfterCreation")
- "OffTestDynamicTypesFilesChangeAfterCreation")
- (("TestDynamicTypesFindExtensionByNameOrNumber")
- "OffTestDynamicTypesFindExtensionByNameOrNumber")))))
;; XXX: Workaround for go-build-system's lack of Go modules
;; support.
(delete 'build)