aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-26 08:31:26 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:23:32 +0000
commit4a28c902e0939835ef98aa96012b26f02bf084b0 (patch)
tree74bcde34e0b12e6219e7c56d810dad0cd966fd4f
parent11684c6429813614dce7b7891b68edd29c20bdec (diff)
downloadguix-4a28c902e0939835ef98aa96012b26f02bf084b0.tar.gz
guix-4a28c902e0939835ef98aa96012b26f02bf084b0.zip
gnu: python-async-timeout: Update to 4.0.3.
* gnu/packages/python-xyz.scm (python-async-timeout): Update to 4.0.3. [build-system]: Swap to pyproject-build-system. [arguments]<phases>: Add 'fix-pytest-config. [native-inputs]: Add python-pytest, python-setuptools, and python-wheel. [descriptin]: Start from a new line. Change-Id: I1f2909d17a5ad3cff60acbd606cdf802fa1e463e
-rw-r--r--gnu/packages/python-xyz.scm25
1 files changed, 19 insertions, 6 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b70fdccdfc..7712a62234 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27983,19 +27983,32 @@ generators and Python 3.7's context managers into Python 3.5.")
(define-public python-async-timeout
(package
(name "python-async-timeout")
- (version "4.0.2")
+ (version "4.0.3")
(source
(origin
(method url-fetch)
(uri (pypi-uri "async-timeout" version))
(sha256
- (base32
- "05bbjz16n1a7m1s3lmcwri2x5rc7hnh6f2hdr2lbflnv1mjf2qr1"))))
- (build-system python-build-system)
+ (base32 "0bsj4z28ggxh1b6h6dvhx2mk6yqgb88bg8lyslpd10jdx1mxjh26"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-pytest-config
+ (lambda _
+ ;; Drop test coverage requirements
+ (substitute* "setup.cfg"
+ ((".*--cov.*") "")))))))
+ (native-inputs
+ (list python-pytest
+ python-setuptools
+ python-wheel))
(home-page "https://github.com/aio-libs/async-timeout")
(synopsis "Timeout context manager for asyncio programs")
- (description "@code{async-timeout} provides a timeout timeout context
-manager compatible with @code{asyncio}.")
+ (description
+ "@code{async-timeout} provides a timeout timeout context manager
+compatible with @code{asyncio}.")
(license license:asl2.0)))
(define-public python-glob2