aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-25 20:23:22 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:23:32 +0000
commit11684c6429813614dce7b7891b68edd29c20bdec (patch)
tree299ec60814b453e7891e5045bff8e0591631e1ee
parent46038c4f44b1a9b34d83e4bc18ecb6c25e91bd5d (diff)
downloadguix-11684c6429813614dce7b7891b68edd29c20bdec.tar.gz
guix-11684c6429813614dce7b7891b68edd29c20bdec.zip
gnu: python-paramiko: Update to 3.5.0.
* gnu/packages/python-crypto.scm (python-paramiko): Update to 3.5.0. [build-system]: Swap to pyproject-build-system. [arguments]<tests>: Enable them. [propagated-inputs]: Add python-invoke. [native-inputs]: Add python-pytest, python-icecream, python-pytest-relaxed, python-pytest-xdist, python-setuptools, and python-wheel. Change-Id: I9ba2f5123ca066d993e8d3c797207179ff8c466b
-rw-r--r--gnu/packages/python-crypto.scm22
1 files changed, 15 insertions, 7 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index b5b3820c3a..eaea26ac24 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -192,19 +192,27 @@ This package provides a Python interface for BLAKE2.")
(define-public python-paramiko
(package
(name "python-paramiko")
- (version "2.7.2")
+ (version "3.5.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "paramiko" version))
(sha256
- (base32 "0dahwq623jnna7gsr9j0mkwr9k2n1pvkapjryhcx508d5jxg8dkz"))))
- (build-system python-build-system)
- (arguments
- `(;; FIXME: Tests require many unpackaged libraries, see dev-requirements.txt.
- #:tests? #f))
+ (base32 "0941n85xi32kvrh2mxppga527a0jz2iz2c99lpfwwmagv90fa4dd"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list python-pytest
+ python-icecream
+ python-pytest-relaxed
+ python-pytest-xdist
+ python-setuptools
+ python-wheel))
(propagated-inputs
- (list python-bcrypt python-pyasn1 python-pynacl python-cryptography))
+ (list python-cryptography
+ python-bcrypt
+ python-invoke
+ python-pyasn1
+ python-pynacl))
(home-page "https://www.paramiko.org/")
(synopsis "SSHv2 protocol library")
(description "Paramiko is a python implementation of the SSHv2 protocol,