aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-05-10 00:53:25 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:50 +0000
commit48c92942ab7037d9cae0e81ef82f4f8697c85e03 (patch)
treed6daddd89676a64dfbb034a5f0f8e627313ff50f
parenta735883a37a2efe6ee34175d950ee5143daaab9c (diff)
downloadguix-48c92942ab7037d9cae0e81ef82f4f8697c85e03.tar.gz
guix-48c92942ab7037d9cae0e81ef82f4f8697c85e03.zip
gnu: python-dateutil: Move to pyproject-build-system.
* gnu/packages/time.scm (python-dateutil): Improve package style. [build-system]: Move to pyproject-build-system. [arguments]: Use <#:test-flags> instead of check phase replacement. Change-Id: I252fbe47f04ba6a2fbcc497565cbf6e352f9d06c Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/time.scm23
1 files changed, 8 insertions, 15 deletions
diff --git a/gnu/packages/time.scm b/gnu/packages/time.scm
index 4d4b746226..e2debd0232 100644
--- a/gnu/packages/time.scm
+++ b/gnu/packages/time.scm
@@ -247,22 +247,15 @@ Pendulum instances.")
(uri (pypi-uri "python-dateutil" version))
(patches (search-patches "python-dateutil-pytest-compat.patch"))
(sha256
- (base32
- "11iy7m4bp2lgfkcl0r6xzf34bvk7ppjmsyn2ygfikbi72v6cl8q1"))))
- (build-system python-build-system)
+ (base32 "11iy7m4bp2lgfkcl0r6xzf34bvk7ppjmsyn2ygfikbi72v6cl8q1"))))
+ (build-system pyproject-build-system)
(arguments
- `(#:phases (modify-phases %standard-phases
- (replace 'check
- (lambda _
- ;; Delete tests that depend on "freezegun" to avoid a
- ;; circular dependency.
- (delete-file "dateutil/test/test_utils.py")
- (delete-file "dateutil/test/test_rrule.py")
-
- ;; XXX: Fails to get timezone from /etc/localtime.
- (delete-file "dateutil/test/test_tz.py")
-
- (invoke "pytest" "-vv"))))))
+ (list
+ #:test-flags '(list ; avoid freezegun dependency
+ "--ignore=dateutil/test/test_utils.py"
+ "--ignore=dateutil/test/test_rrule.py"
+ ;; XXX: Fails to get timezone from /etc/localtime.
+ "--ignore=dateutil/test/test_tz.py")))
(native-inputs
(list python-pytest python-pytest-cov python-setuptools-scm))
(propagated-inputs