aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-05-10 00:53:24 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:50 +0000
commita735883a37a2efe6ee34175d950ee5143daaab9c (patch)
treea57464c9aefe56f153e66f7b87b1c5e9b32e9d29
parent9816aae54342aa2018ce2d827ca14dbb50c62530 (diff)
downloadguix-a735883a37a2efe6ee34175d950ee5143daaab9c.tar.gz
guix-a735883a37a2efe6ee34175d950ee5143daaab9c.zip
gnu: python-pypujs: Improve package style.
* gnu/packages/python-xyz.scm (python-pypujs): Improve package style. [arguments]<#:test-flags>: Use it in place of check phase replacement. <#:phases>: Clarify phase disable-pyramid. Change-Id: If8073cc4e9a8a86003000e7157985fe382de7b4f Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/python-xyz.scm15
1 files changed, 5 insertions, 10 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index febada71ef..0ad615ae73 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6748,18 +6748,13 @@ templates. A format string can be provided to control the output.")
(build-system pyproject-build-system)
(arguments
(list
+ #:test-flags '(list "pypugjs/testsuite/")
#:phases #~(modify-phases %standard-phases
- ;; Our pyramid is outdated and pyramid-mako is not packaged.
(add-after 'unpack 'disable-pyramid
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "setup.py"
- (("'pyramid")
- "#'pyramid"))))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "python" "-m" "pytest" "-v"
- "pypugjs/testsuite/")))))))
+ (lambda _
+ ;; pyramid is outdated and pyramid-mako is unpackaged.
+ (substitute* "setup.cfg"
+ (("'(pyramid|pyramid-mako)[^']*',") "")))))))
(native-inputs (list python-coverage
python-django
python-jinja2