aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-15 13:24:37 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:26 +0200
commit467f367920f81dfc783a75a66f8e0984dca55ff9 (patch)
tree14f6b659fa05b966c73fba8e4367a0a1ce429753
parent7d20f2f976cd8037aa5f7dbe62795b786888007b (diff)
downloadguix-467f367920f81dfc783a75a66f8e0984dca55ff9.tar.gz
guix-467f367920f81dfc783a75a66f8e0984dca55ff9.zip
gnu: texlive-translator: Refresh package definition.
* gnu/packages/tex.scm (texlive-translator): Remove SIMPLE-TEXLIVE-PACKAGE call. [propagated-inputs]: Add TEXLIVE-GRAPHICS.
-rw-r--r--gnu/packages/tex.scm30
1 files changed, 17 insertions, 13 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index cc8a5ac40b..d2051e6af4 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11774,23 +11774,27 @@ document.")
(define-public texlive-translator
(package
- (inherit (simple-texlive-package
- "texlive-translator"
- (list "doc/latex/translator/"
- "tex/latex/translator/")
- (base32 "13rxdqhvgwc5lz2wsw4jwsb92614wlxsa90rmzxyrc6xjz1jypnk")
- #:trivial? #t))
+ (name "texlive-translator")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/translator/"
+ "tex/latex/translator/")
+ (base32
+ "13rxdqhvgwc5lz2wsw4jwsb92614wlxsa90rmzxyrc6xjz1jypnk")))
+ (outputs '("out" "doc"))
(build-system texlive-build-system)
- (home-page "https://ctan.org/macros/latex/contrib/translator")
+ (propagated-inputs
+ (list texlive-graphics))
+ (home-page "https://ctan.org/pkg/translator")
(synopsis "Easy translation of strings in LaTeX")
(description
"This LaTeX package provides a flexible mechanism for translating
-individual words into different languages. For example, it can be used to
-translate a word like \"figure\" into, say, the German word \"Abbildung\".
-Such a translation mechanism is useful when the author of some package would
-like to localize the package such that texts are correctly translated into the
-language preferred by the user. This package is not intended to be used to
-automatically translate more than a few words.")
+individual words into different languages. Such a translation mechanism is
+useful when the author of some package would like to localize the package such
+that texts are correctly translated into the language preferred by the user.
+This package is not intended to be used to automatically translate more than
+a few words.")
(license (list license:lppl license:gpl1+))))
(define-public texlive-textpos