aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-15 13:22:25 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:26 +0200
commit7d20f2f976cd8037aa5f7dbe62795b786888007b (patch)
treeadb23479025b92c77df5d08eafc2736e9aca106e
parentbc9094beb72b132e906b66b3217db7006dd405b5 (diff)
downloadguix-7d20f2f976cd8037aa5f7dbe62795b786888007b.tar.gz
guix-7d20f2f976cd8037aa5f7dbe62795b786888007b.zip
gnu: texlive-xifthen: Refresh package definition.
* gnu/packages/tex.scm (texlive-xifthen): Remove SIMPLE-TEXLIVE-PACKAGE call. [propagated-inputs]: Add TEXLIVE-IFMTARG, TEXLIVE-TOOLS.
-rw-r--r--gnu/packages/tex.scm18
1 files changed, 11 insertions, 7 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 5be52629e6..cc8a5ac40b 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11869,14 +11869,18 @@ by the following fonts:
(define-public texlive-xifthen
(package
- (inherit (simple-texlive-package
- "texlive-xifthen"
- (list "doc/latex/xifthen/"
- "tex/latex/xifthen/")
- (base32
- "0b33mlmnxsj5mi06v2w2zgamk51mgv1lxdr1cax8nkpn9g7n9axw")
- #:trivial? #t))
+ (name "texlive-xifthen")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/xifthen/" "tex/latex/xifthen/")
+ (base32
+ "0b33mlmnxsj5mi06v2w2zgamk51mgv1lxdr1cax8nkpn9g7n9axw")))
+ (outputs '("out" "doc"))
(build-system texlive-build-system)
+ (propagated-inputs
+ (list texlive-ifmtarg
+ texlive-tools))
(home-page "https://ctan.org/pkg/xifthen")
(synopsis "Extended conditional commands")
(description