aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-15 20:37:07 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:49 +0000
commitc98ff7dcff7456ff95e2cb8e4b678e7728e74e76 (patch)
treec093b4fbfa0d957288f358fe19b73830bb37dee4
parentfaea1bad5f5f6b1097aab54d57b620a3ce9d3ae3 (diff)
downloadguix-c98ff7dcff7456ff95e2cb8e4b678e7728e74e76.tar.gz
guix-c98ff7dcff7456ff95e2cb8e4b678e7728e74e76.zip
gnu: Add go-github-com-pascaldekloe-goe.
* gnu/packages/golang-web.scm (go-github-com-pascaldekloe-goe): New variable. Change-Id: Idd1de1f2d2e5aab8c6e257706fefa1960bce53ab
-rw-r--r--gnu/packages/golang-web.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index feb4e6c978..a14d05e4eb 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -4123,6 +4123,38 @@ used to read GeoLite2 and GeoIP2 databases, @code{geoip2} provides a
higher-level API for doing so.")
(license license:isc)))
+(define-public go-github-com-pascaldekloe-goe
+ (package
+ (name "go-github-com-pascaldekloe-goe")
+ (version "0.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pascaldekloe/goe")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1mszfjcc29b6nvw3hs8w33iy6zx6ih5v2jlard0dsrgkpvsx5c81"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/pascaldekloe/goe"
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; XXX: Replace when go-build-system supports nested path.
+ (delete 'build)
+ (replace 'check
+ (lambda* (#:key import-path tests? #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion (string-append "src/" import-path)
+ (invoke "go" "test" "-v" "./..."))))))))
+ (home-page "https://github.com/pascaldekloe/goe")
+ (synopsis "Enterprise tooling for Golang")
+ (description
+ "Common enterprise features for the Go programming language.")
+ (license license:cc0)))
+
(define-public go-github-com-pion-datachannel
(package
(name "go-github-com-pion-datachannel")
nnel-list. Change-Id: I587207b86216f075a54b6ed0b8fa998896bbed74 Signed-off-by: Ludovic Courtès <ludo@gnu.org> Nicolas Graves 2024-08-28home: services: Add home-beets-service-type....* gnu/home/services/music.scm: New file. * gnu/local.mk: Add this. * doc/guix.texi: Document this. Change-Id: Idc23a68276cb3fb07733bb38bc38b1c5a63c1d6a Signed-off-by: Ludovic Courtès <ludo@gnu.org> Fabio Natali 2024-08-18home: Fix typo in parcimonie configuration....* gnu/home/services/gnupg.scm (<home-parcimonie-configuration>) [gnupg-aleady-torified?]: Rename to ‘gnupg-already-torified?’. Change-Id: I0687f67a5cef410b8b1d579c57b318b9d269e0d0 Tobias Geerinckx-Rice 2024-07-26home: Set 700 permissions on .gnupg with home-gpg-agent-service...* gnu/home/services/gnupg.scm (gpg-agent-activation): New variable. (home-gpg-agent-service-type) [extensions]: Extend home-activation-service-type. Change-Id: If3365c6cade2b03ee53a466ce1d63a5cdf654d6c Signed-off-by: Ludovic Courtès <ludo@gnu.org> Richard Sent 2024-05-30home: services: Add home-startx-command-service-type....* gnu/home/services/desktop.scm (home-startx-command-service-type): New variable. (startx-command-service-type): New service-type mapping. * doc/guix.texi (Guix Home Services): Document home-startx-command-service-type. Change-Id: Id38b5dc7b9235e04e3a9a1b70a35b02e8fae95f0 Signed-off-by: Arun Isaac <arunisaac@systemreboot.net> Tomas Volf 2024-04-29home: services: bash: Move default PS1 prompt to bashrc...Fixes <https://issues.guix.gnu.org/70164>. * home/services/shells.scm (add-bash-configuration): Move default PS1 prompt from .bash_profile to .bashrc. Change-Id: Ic437458ee362cc4aa803a71c9962af866749f59a Signed-off-by: Ludovic Courtès <ludo@gnu.org> Richard Sent 2024-04-17services: Add the Guix Home service....This patch adds a Guix Home service, which allows for configuring/deploying an operating-system declaration with an associated home-environment. * gnu/services/guix.scm: Add guix-home-service and guix-home-shepherd-service * gnu/home/services/shepherd.scm: Don't attempt to launch user shepherd when the system shepherd runs guix-home-<user> * doc/guix.texi: Add documentation for guix-home-service * gnu/tests/guix.scm: Add a test to verify guix-home-service-type is able to activate a home environment Change-Id: Ifbcc0878d934aa4abe34bb2123b5081fb432aa8e Signed-off-by: Ludovic Courtès <ludo@gnu.org> Richard Sent 2024-03-27home: services: bash: Reorder aliases....Reported in <https://issues.guix.gnu.org/67652>. * home/services/shells.scm (add-bash-configuration): Reorder aliases. Change-Id: I288856bb6befe378ca60ef78578acc069cb18532 Reported-by: Atte Torri <atte.torri@universite-paris-saclay.fr> Signed-off-by: Hilton Chain <hako@ultrarare.space> Jason Darby 2024-03-21services: shepherd: Load each service file in a fresh module....Fixes <https://issues.guix.gnu.org/67649>. * gnu/home/services/shepherd.scm (home-shepherd-configuration-file)[config]: Define ‘make-user-module’. Call ‘load’ in ‘save-module-excursion’. * gnu/services/shepherd.scm (shepherd-configuration-file): Likewise. Reported-by: Attila Lendvai <attila@lendvai.name> Change-Id: I7df11c81b5bbbf2b24a8daa02502a000e0826fe0 Ludovic Courtès 2024-03-06gnu: home: dotfiles: Properly support both plain and Stow directory layouts....Fixes <https://issues.guix.gnu.org/68848>. The current implementation of the home-dotfiles-service-type contradicts the Guix manual. This patch properly implements both the plain and Stow dotfiles directory layouts. It does so by refactoring home-dotfiles-configuration adding a new packages field to support GNU Stow's users workflow and introducing a new layout field to switch between the two directory layouts. * gnu/home/services/dotfiles (home-dotfiles-configuration): Migrate to (gnu services configuration); [packages]: new field; [layout]: new field; (strip-stow-dotfile): new variable; (strip-plain-dotfile): new variable; (home-dotfiles-configuration->files): use the new fields; [directory-contents]: allow for selecting a subset of application dotfile directories; * doc/guix.texi: document the new layouts. Change-Id: I2e96037608353e360828290f055ec5271cfdfd48 Signed-off-by: Ludovic Courtès <ludo@gnu.org> Giacomo Leidi 2024-02-19home: symlink-manager: Allow busy device skip....* gnu/home/services/symlink-manager.scm (update-symlinks-script): Allow busy device skip. Change-Id: Iff91c8a30309d25c02a8311d8d5ddbf54e90f5ad Signed-off-by: Ludovic Courtès <ludo@gnu.org> Nicolas Graves