aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 15:59:54 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:05:42 +0200
commit452df8748302631b101932d53a4018af6d7a5ad3 (patch)
tree6b317f738ce5ea01691d2d8f47e215be8f540377
parent6442ca4720a4952085506df55a175f213e46404e (diff)
downloadguix-452df8748302631b101932d53a4018af6d7a5ad3.tar.gz
guix-452df8748302631b101932d53a4018af6d7a5ad3.zip
gnu: Add texlive-robustcommand.
* gnu/packages/tex.scm (texlive-robustcommand): New variable.
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index d9cdbb6646..dc5c590daa 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -94118,6 +94118,26 @@ The @code{geometry} package is better if you want to set page layout
parameters to particular measurements.")
(license license:gpl3+)))
+(define-public texlive-robustcommand
+ (package
+ (name "texlive-robustcommand")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/robustcommand/"
+ "source/latex/robustcommand/"
+ "tex/latex/robustcommand/")
+ (base32
+ "0h8j23ww9mrwsnn61f21inxr5m8xsgb60qswk6p8nw89z2zgrl7x")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/robustcommand")
+ (synopsis "Declare robust command, with @code{\\newcommand} checks")
+ (description
+ "The package merely provides a variation of @code{\\DeclareRobustCommand},
+which checks for the existence of a command before declaring it robust.")
+ (license license:lppl)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar