aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgemmaro <gemmaro.dev@gmail.com>2024-08-21 20:59:26 +0900
committerLudovic Courtès <ludo@gnu.org>2024-08-21 18:57:37 +0200
commit410c85f40003dd1209822a930ff54e5ed90fb872 (patch)
tree5691f03b1b412c293c99f83fbdfe2514acf3a311
parent0ecc0a10e8619a92f5fa2612ee33a85e4bc4bc6c (diff)
downloadguix-410c85f40003dd1209822a930ff54e5ed90fb872.tar.gz
guix-410c85f40003dd1209822a930ff54e5ed90fb872.zip
gnu: Add perl-minimumversion.
* gnu/packages/perl.scm (perl-minimumversion): New variable. Change-Id: Iad3c22936c07b7430525ad9827b6703d4ea9ce9c Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/perl.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 46de612234..816aca2d59 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -6877,6 +6877,46 @@ from various sources. For instance, it contains all IANA types and the
knowledge of Apache.")
(license (package-license perl))))
+(define-public perl-minimumversion
+ (package
+ (name "perl-minimumversion")
+ (version "1.40")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/D/DB/DBOOK/Perl-MinimumVersion-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "145yl4qv14xcrr74w1qvdb6s0h5lj8smnfawfnj0rmv0rdwab2bm"))))
+ (build-system perl-build-system)
+ (arguments
+ (list
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'install 'wrap-programs
+ (lambda _
+ (wrap-program (string-append #$output "/bin/perlver")
+ (list "PERL5LIB" ":"
+ 'prefix
+ (list (string-append (getenv "PERL5LIB") ":"
+ #$output
+ "/lib/perl5/site_perl")))))))))
+ (inputs (list bash-minimal))
+ (propagated-inputs (list perl-file-find-rule
+ perl-file-find-rule-perl
+ perl-params-util
+ perl-ppi
+ perl-ppix-regexp
+ perl-ppix-utils))
+ (home-page "https://metacpan.org/release/Perl-MinimumVersion")
+ (synopsis "Find a minimum required version of perl for Perl code")
+ (description
+ "@samp{Perl::MinimumVersion} takes Perl source code and calculates the minimum
+version of perl required to be able to run it. Because it is based on the @samp{PPI}
+(Perl Parsing Interface), it can do this without loading the code. The distribution
+comes with a script called @samp{perlver}.")
+ (license license:perl-license)))
+
(define-public perl-mixin-linewise
(package
(name "perl-mixin-linewise")