aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgemmaro <gemmaro.dev@gmail.com>2024-08-21 20:59:25 +0900
committerLudovic Courtès <ludo@gnu.org>2024-08-21 18:57:34 +0200
commit0ecc0a10e8619a92f5fa2612ee33a85e4bc4bc6c (patch)
tree71c17b7595dae81298d03f1840f693bfb36472ff
parent52ebee34324d9b82b0830b19cb6e1715ae1879ff (diff)
downloadguix-0ecc0a10e8619a92f5fa2612ee33a85e4bc4bc6c.tar.gz
guix-0ecc0a10e8619a92f5fa2612ee33a85e4bc4bc6c.zip
gnu: Add perl-ppix-utils.
* gnu/packages/perl.scm (perl-ppix-utils): New variable. Change-Id: I9548c693aa6f54bd53662374f77b2fbd1ca3f485 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/perl.scm24
1 files changed, 23 insertions, 1 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index a0eec2baed..46de612234 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -33,7 +33,7 @@
;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
;;; Copyright © 2022, 2023 Evgeny Pisemsky <mail@pisemsky.site>
-;;; Copyright © 2022, 2023 gemmaro <gemmaro.dev@gmail.com>
+;;; Copyright © 2022, 2023, 2024 gemmaro <gemmaro.dev@gmail.com>
;;; Copyright © 2023 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
;;; Copyright © 2023 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2023 Jake Leporte <jakeleporte@outlook.com>
@@ -9148,6 +9148,28 @@ replacing the \"@code{PPI}\" at the front of the module name with
in @code{PPIx::Utilities::Node}.")
(license license:perl-license)))
+(define-public perl-ppix-utils
+ (package
+ (name "perl-ppix-utils")
+ (version "0.003")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/D/DB/DBOOK/PPIx-Utils-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "04dszlp7yas3yi7gm1l2g47h88i52n7gwj3jnq0vw0xdivycr6ra"))))
+ (build-system perl-build-system)
+ (propagated-inputs (list perl-b-keywords perl-ppi))
+ (home-page "https://metacpan.org/release/PPIx-Utils")
+ (synopsis "Utility functions for Perl PPI")
+ (description
+ "@samp{PPIx::Utils} is a collection of utility functions for working
+with @samp{PPI} documents. The functions are organized into
+submodules, and may be imported from the appropriate submodules or via
+this module.")
+ (license license:perl-license)))
+
(define-public perl-probe-perl
(package
(name "perl-probe-perl")