aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@friendly-machines.com>2025-02-05 20:29:00 +0100
committerDanny Milosavljevic <dannym@friendly-machines.com>2025-02-05 23:21:43 +0100
commit2fb2cffdd507959f6fd5a3a77ebafcd42ce57a98 (patch)
treef564bd27b99c0c4efa3e985438b5c2a2fb10a90a
parentf89232b10d801933b0196cefb21a547bbec97efb (diff)
downloadguix-2fb2cffdd507959f6fd5a3a77ebafcd42ce57a98.tar.gz
guix-2fb2cffdd507959f6fd5a3a77ebafcd42ce57a98.zip
gnu: Add emacs-pr-review.
* gnu/packages/emacs-xyz.scm (emacs-pr-review): New variable. Change-Id: Ied19b0b58e319d054a15ef6cfa6af7731f728f73
-rw-r--r--gnu/packages/emacs-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index cbd4e25e2b..c0fd08ffca 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -29922,6 +29922,29 @@ turn.")
accept and reject GitHub pull requests.")
(license license:gpl3+))))
+(define-public emacs-pr-review
+ (let ((revision "0")
+ (commit "9fa4ef4d1922cbd6dd37b631ea05aed0ef358178"))
+ (package
+ (name "emacs-pr-review")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/blahgeek/emacs-pr-review.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1cm92263jqvq2lg378xqi8ikbqw98lxjpsl29sja2xg2wf6p7gml"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-magit emacs-ghub emacs-markdown-mode))
+ (synopsis "Review GitHub Pull Requests")
+ (description "This package provides a way to review GitHub Pull
+Requests from magit.")
+ (home-page "https://github.com/blahgeek/emacs-pr-review/")
+ (license license:gpl3+))))
+
(define-public emacs-deadgrep
(package
(name "emacs-deadgrep")