aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-12-17 11:35:23 +0100
committerRicardo Wurmus <rekado@elephly.net>2025-01-20 21:37:22 +0100
commit1df38c9e7b2c8fccfc1989c9288271b07ff495cc (patch)
tree3e31e602972fc60d94b7f16124f7e5a5e0d056a9
parent3121dd2245910f241bc144c629556f9af7505367 (diff)
downloadguix-1df38c9e7b2c8fccfc1989c9288271b07ff495cc.tar.gz
guix-1df38c9e7b2c8fccfc1989c9288271b07ff495cc.zip
gnu: python-colorama: Update to 0.4.6.
* gnu/packages/python-xyz.scm (python-colorama): Update to 0.4.6. [build-system]: Use pyproject-build-system. [native-inputs]: Add python-hatchling and python-pytest. Change-Id: Ifdc20a9dc2a3f21ac59aaaa88fd90abe926595a0
-rw-r--r--gnu/packages/python-xyz.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 95186a385b..7c1a29bf16 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19708,18 +19708,19 @@ for the module to work under Python 3.3.")
(define-public python-colorama
(package
(name "python-colorama")
- (version "0.4.4")
+ (version "0.4.6")
(source
(origin
(method url-fetch)
(uri (pypi-uri "colorama" version))
(sha256
- (base32 "16w62sm95hmh55rqxn4zwdz0bkh3fqm1qnz9cwi3s510iasb4har"))))
- (build-system python-build-system)
+ (base32 "0i3fpq0w5mbfdpy3z9p5raw4fg17jxr6jwh5l8qhavpdnxf5ys88"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-hatchling python-pytest))
+ (home-page "https://pypi.org/project/colorama/")
(synopsis "Colored terminal text rendering for Python")
(description "Colorama is a Python library for rendering colored terminal
text.")
- (home-page "https://pypi.org/project/colorama/")
(license license:bsd-3)))
(define-public python-monthdelta