aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-12-17 11:32:15 +0100
committerRicardo Wurmus <rekado@elephly.net>2025-01-20 21:37:22 +0100
commit3121dd2245910f241bc144c629556f9af7505367 (patch)
treecbea2b795eae911fd6e10eb9f32a3f03146f2292
parent1d8c1b7bf1e3ba79e3acaf2750ef9bce4783f833 (diff)
downloadguix-3121dd2245910f241bc144c629556f9af7505367.tar.gz
guix-3121dd2245910f241bc144c629556f9af7505367.zip
gnu: python-extension-helpers: Update to 1.2.0.
* gnu/packages/python-xyz.scm (python-extension-helpers): Update to 1.2.0. [arguments]: Disable broken test. Change-Id: I3a99240c52fc8114b6eb4d7c3e6642530cf7d756
-rw-r--r--gnu/packages/python-xyz.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ed3a0db888..95186a385b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5423,7 +5423,7 @@ and is not compatible with JSON.")
(define-public python-extension-helpers
(package
(name "python-extension-helpers")
- (version "1.1.1")
+ (version "1.2.0")
(source
(origin
(method git-fetch) ; no tests in the PyPI tarball
@@ -5432,17 +5432,17 @@ and is not compatible with JSON.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1lkhypg21ydx03z03dppbf05zff40dyl0kn6nichzfdfpqnr5055"))))
+ (base32 "1cfzh3ijjp18as2qnmm1nnw6a3daqd7a2q17i0c6h1wq2jbawxxa"))))
(build-system pyproject-build-system)
(arguments
(list
;; It tries to install it via pip: E ModuleNotFoundError: No module named
;; 'helpers_test_package_fd9cc3a9_11fa_4a1a_b80e_c5b043949604'
- #:test-flags #~(list "-k" "not test_only_pyproject[True]")
+ #:test-flags #~(list "-k" "not test_only_pyproject and not test_no_setup_py")
#:phases
#~(modify-phases %standard-phases
;; LookupError: setuptools-scm was unable to detect version for
- ;; /tmp/guix-build-python-extension-helpers-1.1.1.drv-0/source.
+ ;; /tmp/guix-build-python-extension-helpers-1.2.0.drv-0/source.
(add-before 'build 'set-version
(lambda _
(setenv "SETUPTOOLS_SCM_PRETEND_VERSION" #$version)))