aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Wong <wongandj@icloud.com>2025-03-04 13:47:43 -0500
committer宋文武 <iyzsong@member.fsf.org>2025-03-05 15:42:05 +0800
commit18e6031f7405b8b9c38255db1957e1eb064d4632 (patch)
treeabaa8afd18180450e6dd19f21da45f56a51e8184
parentc07778a1491562e02de103f5b988e7f8f2cd6488 (diff)
downloadguix-18e6031f7405b8b9c38255db1957e1eb064d4632.tar.gz
guix-18e6031f7405b8b9c38255db1957e1eb064d4632.zip
gnu: dosbox-staging: Update to 0.82.0.
* gnu/packages/emulators.scm (dosbox-staging): Update to 0.82.0. [arguments]: Enable MT-32 emulation. [inputs]: Add mt32emu, googletest. Change-Id: Ia8ccdd533be6932e2e4fc3660cb472791194523a Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
-rw-r--r--gnu/packages/emulators.scm23
1 files changed, 9 insertions, 14 deletions
diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index 0eafc3df9e..fc31a42934 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -571,7 +571,7 @@ older games.")
;; This is not a patch staging area for DOSBox, but an unaffiliated fork.
(package
(name "dosbox-staging")
- (version "0.81.0")
+ (version "0.82.0")
(source
(origin
(method git-fetch)
@@ -580,32 +580,27 @@ older games.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1fkshxaq12pd72v8m2f3a6d6jk9gh39hn0846gfkfinvw7yykzrl"))))
+ (base32 "1s4c6fiyjm91dnmkval9fvsqszc6yjq5b6pq895xi606dn29b85d"))))
(build-system meson-build-system)
(arguments
- (list #:configure-flags
- #~(list
- ;; These both try to git clone subprojects.
- "-Dunit_tests=disabled" ; gtest
- "-Duse_mt32emu=false")
- #:phases
+ (list #:phases
#~(modify-phases %standard-phases
- (add-after 'unpack 'fix-includes
+ (add-after 'unpack 'skip-failing-tests
(lambda _
- ;; This unnecessary file has an encoding error.
- (delete-file "./src/libs/sdlcd/macosx/SDLOSXCAGuard.h")
- (substitute* (find-files "." "\\.(cpp|h)")
- (("^(#[[:space:]]*include <)(SDL[_.])" _ include file)
- (string-append include "SDL2/" file))))))))
+ (substitute* "tests/meson.build"
+ ;; XXX: This test fails with "Segmentation fault".
+ (("[{].*'shell_cmds'.*,") "")))))))
(native-inputs
(list pkg-config))
(inputs
(list alsa-lib
fluidsynth
+ googletest
iir
libpng
libslirp
mesa
+ mt32emu
opusfile
sdl2
sdl2-image