aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Wong <wongandj@icloud.com>2025-03-04 13:47:42 -0500
committer宋文武 <iyzsong@member.fsf.org>2025-03-05 15:42:05 +0800
commitc07778a1491562e02de103f5b988e7f8f2cd6488 (patch)
treedd35ccfed1164ca43523c3da34fc79f493aec049
parent57f6e13168b862c9e227e20b3983117a6a932a94 (diff)
downloadguix-c07778a1491562e02de103f5b988e7f8f2cd6488.tar.gz
guix-c07778a1491562e02de103f5b988e7f8f2cd6488.zip
gnu: Add mt32emu.
* gnu/packages/audio.scm (mt32emu): New variable. Change-Id: I458e4722ac012935814643a2925e185c46ecaba3 Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
-rw-r--r--gnu/packages/audio.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index e4fde07aac..9fa8df8c19 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -52,6 +52,7 @@
;;; Copyright © 2024 Roman Scherer <roman@burningswell.com>
;;; Copyright © 2025 Junker <dk@junkeria.club>
;;; Copyright © 2025 Sughosha <sughosha@disroot.org>
+;;; Copyright © 2025 Andrew Wong <wongandj@icloud.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2030,6 +2031,34 @@ language and software synthesizer.")
(home-page "https://github.com/markc/midicomp")
(license license:agpl3))))
+(define-public mt32emu
+ (package
+ (name "mt32emu")
+ (version "2.7.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/munt/munt")
+ (commit
+ (string-append "libmt32emu_"
+ (string-replace-substring version "." "_")))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "06d3jzx69nwy9jj6jv9q6rhq5399mp51w6d5mijg3fmwr4al13fd"))))
+ (build-system cmake-build-system)
+ (arguments (list
+ #:tests? #f ;no tests.
+ #:configure-flags #~(list "-Dmunt_WITH_MT32EMU_SMF2WAV=FALSE"
+ "-Dmunt_WITH_MT32EMU_QT=FALSE")))
+ (home-page "https://sourceforge.net/projects/munt/")
+ (synopsis "Pre-GM Roland MIDI device emulator")
+ (description
+ "libmt32emu is a C/C++ library which approximately emulates
+the Roland MT-32, CM-32L and LAPC-I synthesizer modules. It is part of the
+Munt project.")
+ (license license:gpl2+)))
+
(define-public clalsadrv
(package
(name "clalsadrv")