aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-19 14:51:13 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:52 +0200
commit179fc598ec8ef28db3949c7393e32b9afb222819 (patch)
treefa32a790e9dba759817af258804275b80b00e686
parent985069096c6e33bdf5a21622bb3ab94db57654e1 (diff)
downloadguix-179fc598ec8ef28db3949c7393e32b9afb222819.tar.gz
guix-179fc598ec8ef28db3949c7393e32b9afb222819.zip
gnu: Add texlive-octavo.
* gnu/packages/tex.scm (texlive-octavo): New variable.
-rw-r--r--gnu/packages/tex.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index ef8054ba29..cc9eae3584 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6167,6 +6167,32 @@ detective novels, science fiction, and short stories. It is however not
recommended for creating color picture books or dissertations.")
(license (list license:lppl1.3c license:silofl1.1))))
+(define-public texlive-octavo
+ (package
+ (name "texlive-octavo")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/octavo/" "source/latex/octavo/"
+ "tex/latex/octavo/")
+ (base32
+ "10ycj2xg2v7cq4my51dcc749hrrkg2gd41xyrwv1dg1lp9vh7j4z")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/octavo")
+ (synopsis "Typeset books following classical design and layout")
+ (description
+ "The @code{octavo} class is a modification of the standard LaTeX
+@code{book} class. Its purpose is to typeset books following classical design
+and layout principles, with the express intention of encouraging the making of
+beautiful books by anyone with access to a good printer and with an
+inclination towards venerable crafts, e.g., bookbinding. The @code{octavo}
+class differs from the book class by implementing many of the proposals and
+insights of respected experts, especially Jan Tschichold and Hugh Williamson.
+The documentation discusses methods to organise and print out any text into
+signatures, which can then be gathered, folded and sewn into a book.")
+ (license license:lppl)))
+
(define-public texlive-pdftexcmds
(package
(name "texlive-pdftexcmds")