aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-19 14:50:50 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:52 +0200
commit985069096c6e33bdf5a21622bb3ab94db57654e1 (patch)
tree3dcb0790d77ae378540bd637562e30cf1c7bbbda
parent76b2288826ebde2aa6fc87975f16a32e6b3e026d (diff)
downloadguix-985069096c6e33bdf5a21622bb3ab94db57654e1.tar.gz
guix-985069096c6e33bdf5a21622bb3ab94db57654e1.zip
gnu: Add texlive-novel.
* gnu/packages/tex.scm (texlive-novel): New variable.
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index c312f0eb35..ef8054ba29 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6144,6 +6144,29 @@ the NotoSerif, NotoSans and NotoSansMono families of fonts, designed by Steve
Matteson for Google.")
(license (list license:lppl license:silofl1.1))))
+(define-public texlive-novel
+ (package
+ (name "texlive-novel")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/lualatex/novel/"
+ "fonts/opentype/novel/"
+ "tex/lualatex/novel/")
+ (base32
+ "0qg6rs54w1n1vr5dmi6vjks8xn8x04zngk8zz4cv0035jxn4irpc")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/novel")
+ (synopsis "Class for printing fiction, such as novels")
+ (description
+ "This LuaLaTeX document class is specifically written to meet the needs
+of original fiction writers, who are typesetting their own novels for
+non-color print-on-demand technology. The package is well suited for
+detective novels, science fiction, and short stories. It is however not
+recommended for creating color picture books or dissertations.")
+ (license (list license:lppl1.3c license:silofl1.1))))
+
(define-public texlive-pdftexcmds
(package
(name "texlive-pdftexcmds")