aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:02:04 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:06:29 +0200
commit15ac6dd8102182b5effa30149645dc8f8d37d06c (patch)
tree285203da79054bce5f7c942b206f503b81c96653
parentb243fbfd5584009286adde5a131290b6bcbc9e3c (diff)
downloadguix-15ac6dd8102182b5effa30149645dc8f8d37d06c.tar.gz
guix-15ac6dd8102182b5effa30149645dc8f8d37d06c.zip
gnu: Add texlive-subdocs.
* gnu/packages/tex.scm (texlive-subdocs): New variable.
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 53d8e583d4..d2c2a8f3d5 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -96679,6 +96679,27 @@ The default behaviour is to place subscripts slightly lower when there is
a superscript as well, but this can look odd in some situations.")
(license license:lppl)))
+(define-public texlive-subdocs
+ (package
+ (name "texlive-subdocs")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/subdocs/" "tex/latex/subdocs/")
+ (base32
+ "1j30b926n15i3dbdw4xgd241a9g7q084lbalaq7sf4pkjqjj9zh8")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/subdocs")
+ (synopsis "Multifile documents")
+ (description
+ "This is an experimental package aiming to provide a different approach for
+multidocument works (mainly, books with a document per chapter). Unlike the
+@code{\\include} mechanism, every subdocument is a complete normal LaTeX
+document and may be typeset separately. What the package does is sharing the
+@file{.aux} files.")
+ (license license:expat)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar