aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-10-27 22:13:22 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-10-27 22:13:22 +0300
commit13c4d8746be63e8cd4b49c52bb9bbfc873b324dd (patch)
tree764c7ec84ef2c16d9267e42ec9f456e7f4e1cdf1
parentb6e0804953fa310311ad3daf82738f0f03fe20dc (diff)
downloadguix-13c4d8746be63e8cd4b49c52bb9bbfc873b324dd.tar.gz
guix-13c4d8746be63e8cd4b49c52bb9bbfc873b324dd.zip
gnu: python-wtforms: Skip optional tests.
* gnu/packages/python.scm (python-wtforms)[arguments]: Add a phase preventing tests from failing when optional tests aren't run.
-rw-r--r--gnu/packages/python.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 4215c3dc7f..691c5deab0 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -8093,6 +8093,17 @@ python-xdo for newer bindings.)")
(base32
"0vyl26y9cg409cfyj8rhqxazsdnd0jipgjw06civhrd53yyi1pzz"))))
(build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'remove-django-test
+ ;; Don't fail the tests when the inputs for the optional tests cannot be found.
+ (lambda _
+ (substitute*
+ "tests/runtests.py"
+ (("'ext_django.tests', 'ext_sqlalchemy', 'ext_dateutil', 'locale_babel'") "")
+ (("sys.stderr.write(\"### Disabled test '%s', dependency not found\n\" % name)") ""))
+ #t)))))
(native-inputs
`(("unzip" ,unzip)))
(home-page "http://wtforms.simplecodes.com/")
r> 2018-03-13gnu: Add makefile2graph....Christopher Baines 2018-03-08gnu: global: Replace GLOBAL with GNU GLOBAL in description....Clément Lassieur 2018-03-04gnu: cloc: Update phase style....Tobias Geerinckx-Rice 2018-03-04gnu: cloc: Update to 1.76....Tobias Geerinckx-Rice 2018-02-11gnu: global: Update to 6.6.2....Tobias Geerinckx-Rice 2018-02-09gnu: Add colormake....Oleg Pykhalov 2018-02-04gnu: rtags: Update to 2.18....Tobias Geerinckx-Rice 2018-01-31gnu: the-silver-searcher: Update to 2.1.0....Clément Lassieur 2018-01-23gnu: rtags: Fix the bundling issue....Fis Trivial 2018-01-13gnu: lcov: Update to 1.13....Tobias Geerinckx-Rice 2018-01-08gnu: Add rtags....Fis Trivial 2017-12-17gnu: global: Update to 6.6.1 [fixes CVE-2017-17531]....Efraim Flashner 2017-12-12gnu: global: Update to 6.6....Efraim Flashner 2017-10-03gnu: cflow: Fix preprocess option....Oleg Pykhalov 2017-09-11gnu: cloc: Fix typo in description....Tobias Geerinckx-Rice 2017-09-11gnu: cloc: Update to 1.74....Tobias Geerinckx-Rice 2017-08-11gnu: Add cloc....Andy Wingo 2017-06-08gnu: the-silver-searcher: Update to 2.0.0....Clément Lassieur 2017-06-05gnu: global: Update to 6.5.7....Ludovic Courtès 2017-03-30gnu: Use HTTPS for almost all gnu.org HOME-PAGEs....Tobias Geerinckx-Rice 2017-03-15gnu: Use INSTALL-FILE where appropriate....Tobias Geerinckx-Rice