aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 4215c3dc7f..691c5deab0 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -8093,6 +8093,17 @@ python-xdo for newer bindings.)")
(base32
"0vyl26y9cg409cfyj8rhqxazsdnd0jipgjw06civhrd53yyi1pzz"))))
(build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'remove-django-test
+ ;; Don't fail the tests when the inputs for the optional tests cannot be found.
+ (lambda _
+ (substitute*
+ "tests/runtests.py"
+ (("'ext_django.tests', 'ext_sqlalchemy', 'ext_dateutil', 'locale_babel'") "")
+ (("sys.stderr.write(\"### Disabled test '%s', dependency not found\n\" % name)") ""))
+ #t)))))
(native-inputs
`(("unzip" ,unzip)))
(home-page "http://wtforms.simplecodes.com/")