aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-08-18 16:59:17 +0300
committerLudovic Courtès <ludo@gnu.org>2024-08-21 18:55:19 +0200
commit52ebee34324d9b82b0830b19cb6e1715ae1879ff (patch)
tree31402e12349c0fb348f254f9c8efcfcf2d362ce1
parentc2f3f847c34fbad1f246be816172f07b338edbcb (diff)
downloadguix-52ebee34324d9b82b0830b19cb6e1715ae1879ff.tar.gz
guix-52ebee34324d9b82b0830b19cb6e1715ae1879ff.zip
gnu: Add guile-qr-code.
* gnu/packages/guile-xyz.scm (guile-qr-code): New variable. Change-Id: I8891a1ee442040a4f04183fca7bc1eca6a4fc951 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/guile-xyz.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 85c2cfadef..b2ef31ebf7 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -5772,6 +5772,41 @@ a Guile implementation of CBOR.")
(home-page "https://inqlab.net/git/guile-cbor.git")
(license license:gpl3+)))
+(define-public guile-qr-code
+ (package
+ (name "guile-qr-code")
+ (version "0.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/artyom-poptsov/guile-qr-code")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1pbsnkz8pw1x8n9mjq8rm37wmalzbcz98gk8mcfycyd896qdmf4w"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:phases #~(modify-phases %standard-phases
+ (delete 'strip))))
+ (native-inputs (list autoconf
+ automake
+ pkg-config
+ texinfo
+ ;; needed when cross-compiling.
+ guile-3.0
+ guile-lib
+ guile-png))
+ (inputs (list bash-minimal guile-3.0 guile-lib guile-png))
+ (synopsis "Guile QR Code library")
+ (description
+ "GNU Guile QR code generator that can create QR codes from text and binary data.
+The resulting QR codes can be rendered to ASCII art strings or to PNG images (using
+@url{https://github.com/artyom-poptsov/guile-png, Guile-PNG} API.)")
+ (home-page "https://github.com/artyom-poptsov/guile-qr-code")
+ (license (list license:gpl3+ license:expat))))
+
(define-public guile-quickcheck
(package
(name "guile-quickcheck")