aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2024-12-22 17:26:57 +0000
committerDanny Milosavljevic <dannym@friendly-machines.com>2025-01-01 13:05:05 +0100
commit07a352738ad36ba152bd485975a3c90b43e9c2f5 (patch)
tree1a69d739f678ac165523e3f35aa96960a49ff725
parent96b7e92a8fbbe5deca22d0490fd9dd0e54858d4d (diff)
downloadguix-07a352738ad36ba152bd485975a3c90b43e9c2f5.tar.gz
guix-07a352738ad36ba152bd485975a3c90b43e9c2f5.zip
gnu: Add python-sphinx-inline-tabs.
* gnu/packages/sphinx.scm (python-sphinx-inline-tabs): New variable. Change-Id: I92516cdc404cdcaee74cb8cf19f255c049c43021 Signed-off-by: Danny Milosavljevic <dannym@friendly-machines.com>
-rw-r--r--gnu/packages/sphinx.scm23
1 files changed, 22 insertions, 1 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 72f1513f34..f7f3286b7b 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -15,7 +15,7 @@
;;; Copyright © 2019 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2021 Eric Bavier <bavier@posteo.net>
-;;; Copyright © 2021, 2022 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2021, 2022, 2024 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2021 Hugo Lecomte <hugo.lecomte@inria.fr>
;;; Copyright © 2021, 2022, 2024 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
@@ -519,6 +519,27 @@ Blog, News or Announcements section to a Sphinx website.")
(home-page "https://bitbucket.org/prometheus/sphinxcontrib-newsfeed")
(license license:bsd-2)))
+(define-public python-sphinx-inline-tabs
+ (package
+ (name "python-sphinx-inline-tabs")
+ (version "2023.4.21")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "sphinx_inline_tabs" version))
+ (sha256
+ (base32 "1g5yhdk208i8maippnbnijd1knpai809wl3cbwzqy59cc0zz3wjx"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list #:tests? #f)) ; no tests in the release, only in the main branch
+ (native-inputs (list python-flit-core
+ python-sphinx))
+ (home-page "https://github.com/pradyunsg/sphinx-inline-tabs")
+ (synopsis "Add inline tabbed content to your Sphinx documentation")
+ (description "This package provides a Sphinx plugin to add inline tabbed
+content to your Sphinx documentation.")
+ (license license:expat)))
+
(define-public python-sphinx-issues
(package
(name "python-sphinx-issues")