aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorvicvbcun <guix@ikherbers.com>2024-12-22 17:26:56 +0000
committerDanny Milosavljevic <dannym@friendly-machines.com>2025-01-01 13:05:04 +0100
commit96b7e92a8fbbe5deca22d0490fd9dd0e54858d4d (patch)
treee3e82203d0765decb6c1cd4352d99a4b8d4a1382
parent2d0faf10adb6ca49ae7ee84bf8eb0ab2c5e95066 (diff)
downloadguix-96b7e92a8fbbe5deca22d0490fd9dd0e54858d4d.tar.gz
guix-96b7e92a8fbbe5deca22d0490fd9dd0e54858d4d.zip
gnu: pari-gp: Install galdata.
* gnu/packages/algebra.scm (pari-galdata): New variable. (pari-gp)[arguments]<#:phases>: Add phase "install-galdata". Change-Id: Iaec77b0ab60d8ff59c8a36e7e0a7878b58742751 Co-authored by: Vinicius Monego <monego@posteo.net> Change-Id: Id74aa6ce315df48a2d917baf1a436ba54b1b5185 Signed-off-by: Danny Milosavljevic <dannym@friendly-machines.com>
-rw-r--r--gnu/packages/algebra.scm18
1 files changed, 17 insertions, 1 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 32834f1c15..5da77b6318 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -229,6 +229,16 @@ the real span of the lattice.")
(description "fpylll is a Python wrapper for fplll.")
(license license:gpl2+)))
+(define pari-galdata
+ ;; version from 2008-04-12
+ (origin
+ (method url-fetch)
+ ;; no versioning, old files seem to be moved to `old/...' on update
+ (uri "https://pari.math.u-bordeaux.fr/pub/pari/packages/galdata.tgz")
+ (sha256
+ (base32
+ "1pch6bk76f1i6cwwgm7hhxi5h71m52lqayp4mnyj0jmjk406bhdp"))))
+
(define-public pari-gp
(package
(name "pari-gp")
@@ -253,7 +263,13 @@ the real span of the lattice.")
(lambda _
(invoke "./Configure"
"--mt=pthread"
- (string-append "--prefix=" #$output)))))))
+ (string-append "--prefix=" #$output))))
+ (add-after 'install 'install-galdata
+ (lambda _
+ (invoke "tar" "-xvf" #$pari-galdata)
+ (copy-recursively "data/" (string-append
+ #$output
+ "/share/pari")))))))
(synopsis "PARI/GP, a computer algebra system for number theory")
(description
"PARI/GP is a widely used computer algebra system designed for fast