aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2024-07-26 13:06:12 -0400
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:45:44 +0200
commit0618dda2ab06c9bbc4b43c868cd01beba75b1053 (patch)
tree26240b2b5c1283a03b6899d4c74328cf09461084
parentdd3b79e7a1ba21b89b2b1cfc6b8679fdd63c96b2 (diff)
downloadguix-0618dda2ab06c9bbc4b43c868cd01beba75b1053.tar.gz
guix-0618dda2ab06c9bbc4b43c868cd01beba75b1053.zip
gnu: python-urwid: Update to 2.6.15.
* gnu/packages/python-xyz.scm (python-urwid): Update to 2.6.15. [build-system]: Use PYPROJECT-BUILD-SYSTEM. [arguments]: Skip the test suite. [propagated-inputs]: Add PYTHON-TYPING-EXTENSIONS and PYTHON-WCWIDTH. [native-inputs]: Add PYTHON-SETUPTOOLS-SCM. Change-Id: I13e242c4a1ec8a1ba6fad759e261468eb831eeb3
-rw-r--r--gnu/packages/python-xyz.scm15
1 files changed, 11 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index cde5c91e4a..a7688050e1 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12904,24 +12904,31 @@ computing.")
(define-public python-urwid
(package
(name "python-urwid")
- (version "2.1.2")
+ (version "2.6.15")
(source
(origin
(method url-fetch)
(uri (pypi-uri "urwid" version))
(sha256
(base32
- "1bky2bra6673xx8jy0826znw6cmxs89wcwwzda8d025j3jffx2sq"))))
- (build-system python-build-system)
+ "06v7m5xayyglzv630qsbg7zh6k37h6k94w7x7xkdkj481lrmgk4y"))))
+ (build-system pyproject-build-system)
(arguments
(list
+ ;; XXX The test suite requires python-tornado but fails to find it
+ ;; whether or not it is available in the build environment.
+ #:tests? #f
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'remove-vterm-tests
;; According to Debian these tests are cursed.
;; https://salsa.debian.org/python-team/packages/urwid/-/blob/debian/2.1.2-2/debian/changelog#L141
(lambda _
- (delete-file "urwid/tests/test_vterm.py"))))))
+ (delete-file "tests/test_vterm.py"))))))
+ (propagated-inputs
+ (list python-typing-extensions python-wcwidth))
+ (native-inputs
+ (list python-setuptools-scm))
(home-page "https://urwid.org")
(synopsis "Console user interface library for Python")
(description