aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2024-07-26 11:03:48 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:45:44 +0200
commitdd3b79e7a1ba21b89b2b1cfc6b8679fdd63c96b2 (patch)
treeb9c1f6c10a43efabd0aa5ea73b5f5bd0e1751749
parent7aabf2daf2a88aaec3126ad01365ece188f2b1cf (diff)
downloadguix-dd3b79e7a1ba21b89b2b1cfc6b8679fdd63c96b2.tar.gz
guix-dd3b79e7a1ba21b89b2b1cfc6b8679fdd63c96b2.zip
gnu: nss: Use ‘datefudge’ to run tests on 32-bit platforms.
Fixes <https://issues.guix.gnu.org/72239>. * gnu/packages/nss.scm (nss)[arguments]: In ‘check’ phase, on 32-bit platforms, modify ‘SOURCE_DIR’ in ‘gtests.sh’ and use ‘datefudge’ rather than ‘faketime’. [native-inputs]: On 32-bit platforms, use ‘datefudge’ rather than ‘libfaketime’. Change-Id: I6b35f4d979897dd2215e189c4375aa0d792530d0
-rw-r--r--gnu/packages/nss.scm19
1 files changed, 16 insertions, 3 deletions
diff --git a/gnu/packages/nss.scm b/gnu/packages/nss.scm
index d2d0b33180..6c60e9fbae 100644
--- a/gnu/packages/nss.scm
+++ b/gnu/packages/nss.scm
@@ -40,7 +40,8 @@
#:use-module (gnu packages crates-io)
#:use-module (gnu packages compression)
#:use-module (gnu packages perl)
- #:use-module (gnu packages sqlite))
+ #:use-module (gnu packages sqlite)
+ #:use-module (gnu packages time))
(define-public nspr
(package
@@ -213,11 +214,21 @@ in the Mozilla clients.")
(substitute* "nss/tests/dbtests/dbtests.sh"
((" -lt 5") " -lt 50"))
+ #$@(if (target-64bit?)
+ '()
+ ;; The script fails to determine the source
+ ;; directory when running under 'datefudge' (see
+ ;; <https://issues.guix.gnu.org/72239>). Help it.
+ #~((substitute* "nss/tests/gtests/gtests.sh"
+ (("SOURCE_DIR=.*")
+ (string-append "SOURCE_DIR=" (getcwd) "/nss\n")))))
+
;; The "PayPalEE.cert" certificate expires every six months,
;; leading to test failures:
;; <https://bugzilla.mozilla.org/show_bug.cgi?id=609734>. To
;; work around that, set the time to roughly the release date.
- (invoke "faketime" "2024-01-23" "./nss/tests/all.sh"))
+ (invoke #$(if (target-64bit?) "faketime" "datefudge")
+ "2024-01-23" "./nss/tests/all.sh"))
(format #t "test suite not run~%"))))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
@@ -242,7 +253,9 @@ in the Mozilla clients.")
(copy-recursively (string-append obj "/lib") lib)))))))
(inputs (list sqlite zlib))
(propagated-inputs (list nspr)) ;required by nss.pc.
- (native-inputs (list perl libfaketime which)) ;for tests
+ (native-inputs (list perl ;for tests
+ (if (target-64bit?) libfaketime datefudge)
+ which))
;; The NSS test suite takes around 48 hours on Loongson 3A (MIPS) when
;; another build is happening concurrently on the same machine.