aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-11-27 18:14:28 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-11-27 18:14:28 +0200
commit050407b473ac755c911be678b02626d40b25c122 (patch)
treeba45f043af2c730af1bde8640c745db7d32a6741
parentc6d15cf27a137051ccd8f301330a70dd0eecc3d4 (diff)
downloadguix-050407b473ac755c911be678b02626d40b25c122.tar.gz
guix-050407b473ac755c911be678b02626d40b25c122.zip
gnu: vim: Update to 9.1.0889.
* gnu/packages/vim.scm (vim): Update to 9.1.0889. [arguments]: Adjust the custom 'skip-or-fix-failing-tests to skip another test. Change-Id: I82806677bd9e33c6e683e3befb563631b4947cbe
-rw-r--r--gnu/packages/vim.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index a7f07ec0f6..6deebdaf2e 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -86,7 +86,7 @@
(define-public vim
(package
(name "vim")
- (version "9.1.0744")
+ (version "9.1.0889")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -95,7 +95,7 @@
(file-name (git-file-name name version))
(sha256
(base32
- "0izx8ckjbpavp3bpw7lzdga5mmpcdssvzhlnz18n4bfzpfhg5knr"))))
+ "1ma8g9zqqbr7pkwkb9zl62n80av18cb7yswq51fciwq3gb2hww5m"))))
(build-system gnu-build-system)
(arguments
`(#:test-target "test"
@@ -134,6 +134,10 @@
(substitute* "src/testdir/test_writefile.vim"
(("!has\\('bsd'\\)") "0")))
+ ;; These tests crash the build environment.
+ (substitute* "src/testdir/Make_all.mak"
+ ((".*test_glvs.*") ""))
+
;; These tests check how the terminal looks after executing some
;; actions. The path of the bash binary is shown, which results in
;; a difference being detected. Patching the expected result is