aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/vim.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/vim.scm')
-rw-r--r--gnu/packages/vim.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index a7f07ec0f6..6deebdaf2e 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -86,7 +86,7 @@
(define-public vim
(package
(name "vim")
- (version "9.1.0744")
+ (version "9.1.0889")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -95,7 +95,7 @@
(file-name (git-file-name name version))
(sha256
(base32
- "0izx8ckjbpavp3bpw7lzdga5mmpcdssvzhlnz18n4bfzpfhg5knr"))))
+ "1ma8g9zqqbr7pkwkb9zl62n80av18cb7yswq51fciwq3gb2hww5m"))))
(build-system gnu-build-system)
(arguments
`(#:test-target "test"
@@ -134,6 +134,10 @@
(substitute* "src/testdir/test_writefile.vim"
(("!has\\('bsd'\\)") "0")))
+ ;; These tests crash the build environment.
+ (substitute* "src/testdir/Make_all.mak"
+ ((".*test_glvs.*") ""))
+
;; These tests check how the terminal looks after executing some
;; actions. The path of the bash binary is shown, which results in
;; a difference being detected. Patching the expected result is