aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2018 Christopher Baines <mail@cbaines.net>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages terraform)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix git-download)
  #:use-module (guix build-system go))

(define-public terraform-docs
  (package
    (name "terraform-docs")
    (version "0.6.0")
    (source (origin
              (method git-fetch)
              (uri (git-reference
                    (url "https://github.com/segmentio/terraform-docs")
                    (commit (string-append "v" version))))
              (file-name (git-file-name name version))
              (sha256
               (base32
                "1p6prhjf82qnhf1zwl9h92j4ds5g383a6g9pwwnqbc3wdwy5zx7d"))))
    (build-system go-build-system)
    (arguments
     '(#:import-path "github.com/segmentio/terraform-docs"))
    (synopsis "Generate documentation from Terraform modules")
    (description
     "The @code{terraform-docs} utility can generate documentation describing
the inputs and outputs for modules of the Terraform infrastructure management
tool.  These can be shown, or written to a file in JSON or Markdown formats.")
    (home-page "https://github.com/segmentio/terraform-docs")
    (license license:expat)))
me-development.scm?id=d23ced7cc1d59af4bf8cac28e332ca29bc7b93e1'>gnu: mygui: Update to 3.4.2....* gnu/packages/game-development.scm (mygui): Update to 3.4.2. (mygui-gl)[inputs]: Add libglvnd, and a union of sdl2 and sdl2-image. Tobias Geerinckx-Rice 2023-07-16gnu: ode: Update to 0.16.4....* gnu/packages/game-development.scm (ode): Update to 0.16.4. Tobias Geerinckx-Rice 2023-07-09gnu: Remove top-level (guix build utils) import....* gnu/packages/game-development.scm: Don't import (guix build utils) here. Tobias Geerinckx-Rice 2023-07-14gnu: godot: Update to 4.1. Rename godot@3 to godot-lts....* gnu/packages/game-development.scm (godot): Update to 4.1. [source]: Update snippet: remove embree and enet; add amd-fsr, astcenc, basis_universal, brotli, linuxbsd_headers, etcpak, meshoptimizer, msdfgen, noise, openxr, rvo2, spirv-reflect, thorvg, volk, vulkan. [arguments]: Remove #:scons. Update #:scons-flags to unbundle more libraries. [phases]: Remove 'build-headless phase (headless is no longer has a separate build). Add 'fix-dl-open-paths and 'unbundle-xkbcommon phases. In 'install phase, remove headless output. Update 'wrap phase to remove eudev. [outputs]: Remove headless. [inputs]: Add dbus, embree, enet, fontconfig, glslang, libpng, harfbuzz, icu4c, libxkbcommon, openxr, speech-dispatcher, vulkan-loader, zlib. Remove bullet. Rename freetype to freetype-with-brotli. (godot-lts): New variable. godot@3 is the LTS release. * gnu/packages/games.scm (superstarfighter)[native-inputs]: Use it. [inputs]: Use it. John Kehayias 2023-07-11gnu: guile-chickadee: Change license to Apache 2.0....* gnu/packages/game-development.scm (guile-chickadee)[license]: Change to Apache 2.0 (asl2.0). Signed-off-by: Ludovic Courtès <ludo@gnu.org> Morgan Smith 2023-07-09gnu: ode: Skip tests when cross-compiling....* gnu/packages/game-development.scm (ode)[arguments]: Adjust #:tests? to skip tests when cross-compiling. Efraim Flashner 2023-06-20gnu: recastnavigation: Update to 1.6.0....* gnu/packages/game-development.scm (recastnavigation): Update to 1.6.0. Signed-off-by: Christopher Baines <mail@cbaines.net> Kaelyn Takata 2023-05-28gnu: python-renpy: Use G-Expressions....* gnu/packages/game-development.scm (python-renpy)[arguments]: Convert to list of G-Expressions. Liliana Marie Prikler 2023-05-28gnu: python-renpy: Update to 8.1.0....* gnu/packages/game-development.scm (python-renpy): Update to 8.1.0. [source]: No longer unbundle fribidi. Drop sync service and report as official version. [arguments]<#:phases>: Drop ‘fix-include-paths’. [propagated-inputs]: Add python-ecdsa. Liliana Marie Prikler 2023-05-28gnu: python-pygame-sdl2: Use G-Expressions....* gnu/packages/game-development.scm (python-pygame-sdl2)[arguments]: Convert to list of G-Expressions. Liliana Marie Prikler 2023-05-28gnu: python-pygame-sdl2: Update to 2.1.0-for-renpy-8.1.0....* gnu/packages/game-development.scm (python-pygame-sdl2): Update to 2.1.0-for-renpy-8.1.0. Liliana Marie Prikler 2023-05-24gnu: guile-chickadee: Update to 0.10.0....* gnu/packages/game-development.scm (guile-chickadee): Update to 0.10.0. David Thompson 2023-05-19gnu: openmw: Fix build on glibc 2.34 and newer....* gnu/packages/patches/openmw-assume-nonconst-SIGSTKSZ.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it here. * gnu/packages/game-development.scm (openmw)[source]<patches>: Use it here. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Kaelyn Takata 2023-05-19gnu: recastnavigation: Update to commit 6d1f971....* gnu/packages/game-development.scm (recastnavigation): Update to commit 6d1f971. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Kaelyn Takata 2023-05-14gnu: Add bbcsdl....* gnu/packages/game-development.scm (bbcsdl): New variable. 宋文武 2023-05-13gnu: raylib: Fix audio and use system glfw....* gnu/packages/game-development.scm (raylib)[inputs]: Use glfw and pluseaudio. [arguments]: Set flags for glfw and pulseaudio. 宋文武 2023-05-13gnu: raylib: Update to 4.5.0....* gnu/packages/game-development.scm (raylib): Update to 4.5.0. 宋文武