aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-07-09 10:20:02 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-07-09 10:43:02 +0300
commit7ba92bd38fbcc622d33e853600adaa6343ecdf8b (patch)
treef0f90011c697226204174db4a57fe943d74cb3a7 /gnu/packages/game-development.scm
parent533d2b83a1c654369cbd7be1b9bf065c0b6c76a5 (diff)
downloadguix-7ba92bd38fbcc622d33e853600adaa6343ecdf8b.tar.gz
guix-7ba92bd38fbcc622d33e853600adaa6343ecdf8b.zip
gnu: ode: Skip tests when cross-compiling.
* gnu/packages/game-development.scm (ode)[arguments]: Adjust #:tests? to skip tests when cross-compiling.
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index aa99109cca..e8d194131f 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -4,7 +4,7 @@
;;; Copyright © 2015, 2018, 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015, 2018 Alex Kost <alezost@gmail.com>
;;; Copyright © 2015, 2016, 2017 David Thompson <davet@gnu.org>
-;;; Copyright © 2016, 2017, 2018, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016-2021, 2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016, 2017, 2020 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2016, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016, 2017, 2018 Julian Graham <joolean@gmail.com>
@@ -2427,7 +2427,8 @@ a.k.a. XenoCollide) as described in Game Programming Gems 7.")
(arguments
(list
;; XXX: The sole test is failing on i686 due to a rounding error.
- #:tests? (not (target-x86-32?))
+ #:tests? (not (or (target-x86-32?)
+ (%current-target-system)))
#:configure-flags #~(list "-DODE_WITH_LIBCCD_SYSTEM=ON")
#:phases
#~(modify-phases %standard-phases