aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-05-19 12:13:40 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-05-28 23:14:19 +0200
commit1b3c9ef96ea44f57abbea6941621715b056489b3 (patch)
tree5b8bd5a4aea297c306ef83854ead2a33d210b935 /gnu/packages/game-development.scm
parent12fcdbd4095b89654bb0f62b6fab01b32cd4e50c (diff)
downloadguix-1b3c9ef96ea44f57abbea6941621715b056489b3.tar.gz
guix-1b3c9ef96ea44f57abbea6941621715b056489b3.zip
gnu: python-pygame-sdl2: Use G-Expressions.
* gnu/packages/game-development.scm (python-pygame-sdl2)[arguments]: Convert to list of G-Expressions.
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm32
1 files changed, 16 insertions, 16 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 9333a82a6a..272032a196 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1298,22 +1298,22 @@ and multimedia programs in the Python language.")
(delete-file-recursively "gen-static")))))
(build-system python-build-system)
(arguments
- `(#:tests? #f ; tests require pygame to be installed first
- #:phases
- (modify-phases %standard-phases
- (add-after 'set-paths 'set-sdl-vars
- (lambda* (#:key inputs #:allow-other-keys)
- (setenv "PYGAME_SDL2_CFLAGS"
- (string-append "-I"
- (assoc-ref inputs "sdl-union")
- "/include/SDL2 -D_REENTRANT"))
- (setenv "PYGAME_SDL2_LDFLAGS"
- (string-append "-L"
- (assoc-ref inputs "sdl-union")
- "/lib -Wl,-rpath,"
- (assoc-ref inputs "sdl-union")
- "/lib -Wl,--enable-new-dtags -lSDL2"))
- #t)))))
+ (list
+ #:tests? #f ; tests require pygame to be installed first
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'set-paths 'set-sdl-vars
+ (lambda* (#:key inputs #:allow-other-keys)
+ (setenv "PYGAME_SDL2_CFLAGS"
+ (string-append "-I"
+ (assoc-ref inputs "sdl-union")
+ "/include/SDL2 -D_REENTRANT"))
+ (setenv "PYGAME_SDL2_LDFLAGS"
+ (string-append "-L"
+ (assoc-ref inputs "sdl-union")
+ "/lib -Wl,-rpath,"
+ (assoc-ref inputs "sdl-union")
+ "/lib -Wl,--enable-new-dtags -lSDL2")))))))
(inputs
(list (sdl-union (list sdl2 sdl2-image sdl2-mixer sdl2-ttf))))
(native-inputs