aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Joshua S. Grant <jgrant@parenthetical.io>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages libffcall)
  #:use-module ((guix licenses) #:prefix l:)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu))

(define-public libffcall
   (package
    (name "libffcall")
    (version "2.2")
    (source
     (origin
       (method url-fetch)
       (uri (string-append
             "mirror://gnu/libffcall/libffcall-" version ".tar.gz"))
       (sha256
        (base32
         "0ixp7kbr7y8s34nsrsdfh77ig5c2zkwr6cfg9v1gm53cggwkgypb"))))
    (build-system gnu-build-system)
    (arguments
     '(#:parallel-build? #f
       #:configure-flags '("--disable-static")))
    (synopsis "Foreign function calls from interpreters")
    (description
     "GNU Libffcall is a collection of libraries that can be used to build
foreign function call interfaces in embedded interpreters.")
    (home-page "https://www.gnu.org/software/libffcall/")
    (license l:gpl2+)))
...* gnu/packages/ftp.scm (libfilezilla): Update to 0.30.0. (filezilla): Update to 3.55.0. Tobias Geerinckx-Rice 2021-07-02gnu: libfilezilla: Update to 0.29.0....* gnu/packages/ftp.scm (libfilezilla): Update to 0.29.0. Tobias Geerinckx-Rice 2021-07-02gnu: vsftpd: Properly enable the SSL support....* gnu/packages/ftp.scm (vsftpd)[arguments]: Remove (questionable?) "-lcrypt" from LDFLAGS. #define VSF_BUILD_SSL in a new 'build-SSL phase instead. Tobias Geerinckx-Rice 2021-07-02gnu: vsftpd: Edit description....Address ‘guix lint’ warnings. Neither tiptoe around the name nor sell anything. * gnu/packages/ftp.scm (vsftpd)[synopsis]: Make useful. [description]: Use its full name and some nice mark-up. Tobias Geerinckx-Rice 2021-07-02gnu: vsftpd: Cross-compile....* gnu/packages/ftp.scm (vsftpd)[arguments]: Use CC-FOR-TARGET. Tobias Geerinckx-Rice 2021-07-02gnu: vsftpd: Let the build system create directories....* gnu/packages/ftp.scm (vsftpd)[arguments]: Pass the "-D" flag to ‘install’. Remove the now redundant 'mkdir phase. Tobias Geerinckx-Rice 2021-07-02gnu: vsftpd: Honour upstream make flags....* gnu/packages/ftp.scm (vsftpd)[arguments]: Add a new 'append-make-flags phase. Remove our now redundant "-pie" from LDFLAGS. Tobias Geerinckx-Rice 2021-07-02gnu: vsftpd: Update to 3.0.4....* gnu/packages/ftp.scm (vsftpd): Update to 3.0.4. [source]: Build from the regular upstream tarball again. [arguments]: Add ‘-lcap’ and ‘-lpam’ to LDFLAGS. Remove obsolete custom 'unpack and 'apply-CentOS-patches phases. [native-inputs]: Remove p7zip and cpio. Tobias Geerinckx-Rice 2021-05-23gnu: filezilla: Update to 3.54.1....* gnu/packages/ftp.scm (filezilla): Update to 3.54.1. Tobias Geerinckx-Rice 2021-05-06gnu: filezilla: Update to 3.53.1....* gnu/packages/ftp.scm (filezilla): Update to 3.53.1. Tobias Geerinckx-Rice 2021-05-06gnu: libfilezilla: Update to 0.28.0....* gnu/packages/ftp.scm (libfilezilla): Update to 0.28.0. [native-inputs]: Add gcc-8. Tobias Geerinckx-Rice 2021-04-05gnu: ncftp: Add 'release-monitoring-url' property....* gnu/packages/ftp.scm (ncftp)[properties]: New field. Ludovic Courtès 2021-03-30gnu: vsftp: Apply unstaged fixes....* gnu/packages/ftp.scm (vsftpd): Update comment. [version]: Separate version and revision with a hyphen. Tobias Geerinckx-Rice 2021-03-30gnu: vsftpd: Use CentOS version and patches....* gnu/packages/ftp.scm (vftpd)[source]: Use CentOS source RPM. [arguments]: Adapt the 'unpack phase, and apply CentOS patches in a new 'apply-CentOS-patches phase. [inputs]: Add openssl, linux-pam, and libcap. [native-inputs]: Add p7zip and cpio. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr> methuselah-0