aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ftp.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-07-02 04:53:35 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-07-02 07:14:10 +0200
commit26f31c7c9a3351b9c5675c63f2f1609ef27fd9a9 (patch)
tree2df7fe0d6a5d9b75d8cfe771829dda37baf93cde /gnu/packages/ftp.scm
parentc2533c3da2f277babb9f64e875896f24a51ff4a6 (diff)
downloadguix-26f31c7c9a3351b9c5675c63f2f1609ef27fd9a9.tar.gz
guix-26f31c7c9a3351b9c5675c63f2f1609ef27fd9a9.zip
gnu: vsftpd: Edit description.
Address ‘guix lint’ warnings. Neither tiptoe around the name nor sell anything. * gnu/packages/ftp.scm (vsftpd)[synopsis]: Make useful. [description]: Use its full name and some nice mark-up.
Diffstat (limited to 'gnu/packages/ftp.scm')
-rw-r--r--gnu/packages/ftp.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/ftp.scm b/gnu/packages/ftp.scm
index cd51ec5a15..68424c1591 100644
--- a/gnu/packages/ftp.scm
+++ b/gnu/packages/ftp.scm
@@ -293,9 +293,11 @@ directory comparison and more.")
`(("libcap" ,libcap)
("linux-pam" ,linux-pam)
("openssl" ,openssl)))
- (synopsis "vsftpd FTP daemon")
- (description "@command{vsftpd} is a daemon that listens on a TCP socket
-for clients and gives them access to local files via File Transfer
-Protocol.")
+ (synopsis "Small FTP server with a focus on security")
+ (description
+ "The Very Secure File Transfer Protocol Daemon or @command{vsftpd} is a
+server that listens on a TCP socket for clients and gives them access to local
+files via @acronym{FTP, the File Transfer Protocol}. Security is a goal; not a
+guarantee.")
(home-page "https://security.appspot.com/vsftpd.html")
- (license gpl2)))
+ (license gpl2))) ; with OpenSSL exception
iv class='ctx'>
$(map_get EXPORTCODES $FILEKEY)
-})}).fun();") > $BUILDDIR/$FILE
+})}).fun();") > "$BUILDDIR"/$FILE
fi
done
if [ "$BROWSER" = "chromium" ]; then
- cat > $BUILDDIR/exports_init.js <<EOF
+ cat > "$BUILDDIR"/exports_init.js <<EOF
window.killtheweb={is_chrome: true, browser: window.chrome};
EOF
else
- cat > $BUILDDIR/exports_init.js <<EOF
+ cat > "$BUILDDIR"/exports_init.js <<EOF
/* Polyfill for IceCat 60. */
String.prototype.matchAll = String.prototype.matchAll || function(regex) {
if (regex.flags.search("g") === -1)
@@ -280,18 +280,18 @@ window.killtheweb={is_mozilla: true, browser: this.browser};
EOF
fi
- cp -r copyright licenses/ $BUILDDIR
- cp html/*.css $BUILDDIR/html
- mkdir $BUILDDIR/icons
- cp icons/*.png $BUILDDIR/icons
+ cp -r copyright licenses/ "$BUILDDIR"
+ cp html/*.css "$BUILDDIR"/html
+ mkdir "$BUILDDIR"/icons
+ cp icons/*.png "$BUILDDIR"/icons
if [ "$BROWSER" = "chromium" ]; then
- for MOZILLA_FILE in $(find $BUILDDIR -name "MOZILLA_*"); do
+ for MOZILLA_FILE in $(find "$BUILDDIR" -name "MOZILLA_*"); do
echo > "$MOZILLA_FILE"
done
fi
if [ "$BROWSER" = "mozilla" ]; then
- for CHROMIUM_FILE in $(find $BUILDDIR -name "CHROMIUM_*"); do
+ for CHROMIUM_FILE in $(find "$BUILDDIR" -name "CHROMIUM_*"); do
echo > "$CHROMIUM_FILE"
done
fi