aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-10-24 18:50:09 +0000
committerRicardo Wurmus <rekado@elephly.net>2021-10-24 18:50:09 +0000
commitcc331ad7eb27d31c597cf1857a2f5fe4ced0f01d (patch)
tree6ba2153855edf0fcd0cc9192300be853afb10b94
parent084bdf9d694e924aa82673cc2aeeb3f9d78199c5 (diff)
downloadguix-cc331ad7eb27d31c597cf1857a2f5fe4ced0f01d.tar.gz
guix-cc331ad7eb27d31c597cf1857a2f5fe4ced0f01d.zip
gnu: flexbar: Use TBB 2020.
* gnu/packages/bioinformatics.scm (flexbar)[inputs]: Replace tbb with tbb-2020.
-rw-r--r--gnu/packages/bioinformatics.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index dfb260a90e..98e9c78085 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3595,7 +3595,7 @@ results. The FASTX-Toolkit tools perform some of these preprocessing tasks.")
(bin (string-append out "/bin/")))
(install-file "flexbar" bin)))))))
(inputs
- `(("tbb" ,tbb)
+ `(("tbb" ,tbb-2020)
("zlib" ,zlib)))
(native-inputs
`(("pkg-config" ,pkg-config)
r>2020-06-24nix: Tweak .gitignore files....Remove .gitignore entries where they match source files that are tracked in Git. This is relevant to me at least, as some code searching tools use .gitignore files and will ignore matched files. Christopher Baines 2020-03-26daemon: Avoid kill -1 bug on the Hurd....This allows for native builds on the Hurd, doing sudo ./pre-inst-env guix-daemon --disable-chroot --build-users-group=guixbuild & ./pre-inst-env guix build hello * nix/libutil/util.cc (killUser)[__GNU__]: Avoid kill -1 bug; kill only current process and ignore SIGKILL status in parent. Co-authored-by: Jan Nieuwenhuizen <janneke@gnu.org> Manolis Ragkousis 2020-01-12daemon: Account for deleted store files when deduplication is on....Previously, a store item that is a regular file would not be accounted for in the 'bytesFreed' value computed by 'deletePath' because its 'st_nlink' count would always be >= 2. This commit fixes that. * nix/libutil/util.hh (deletePath): Add optional 'linkThreshold' argument. * nix/libutil/util.cc (_deletePath): Add 'linkThreshold' argument and honor it. Pass it down in recursive call. (deletePath): Add 'linkThreshold' and honor it. * nix/libstore/gc.cc (LocalStore::deleteGarbage): Pass 'linkThreshold' argument to 'deletePath', with a value of 2 when PATH is a store item and deduplication is on. Ludovic Courtès