aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
;;; Copyright © 2016, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018, 2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages iso-codes)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix git-download)
  #:use-module (guix build-system gnu)
  #:use-module (guix build-system python)
  #:use-module (guix build-system pyproject)
  #:use-module (gnu packages check)
  #:use-module (gnu packages gettext)
  #:use-module (gnu packages perl)
  #:use-module (gnu packages python)
  #:use-module (gnu packages python-build)
  #:use-module (gnu packages python-science))

(define-public iso-codes/official
  ;; This package variant is intended for ‘external’ use, such as users running
  ;; ‘guix install’, where any deviation from ISO gospel might be harmful.
  (package
    (name "iso-codes")
    (version "4.5.0")
    (home-page "https://salsa.debian.org/iso-codes-team/iso-codes")
    (source (origin
             (method git-fetch)
             (uri (git-reference
                   (url home-page)
                   (commit (string-append "iso-codes-" version))))
             (file-name (git-file-name name version))
             (sha256
              (base32
               "1q6x9c5x4x0x4q11iygldsmxdyzhz1mb4n8im76glwsgqsqyjs80"))))
    (build-system gnu-build-system)
    (native-inputs
     (list gettext-minimal perl python-wrapper))
    (synopsis "Various ISO standards")
    (description
     "This package provides lists of various ISO standards (e.g. country,
language, language scripts, and currency names) in one place, rather
than repeated in many programs throughout the system.

Currently there are lists of languages and countries embedded in
several different programs, which leads to dozens of lists of
200 languages, translated into more than 30 languages... not
very efficient.

With this package, we create a single \"gettext domain\" for every
supported ISO standard which contains the translations of
that domain.  It is easy for a programmer to re-use those
translations instead of maintaining their own translation
infrastructure.  Moreover, the programmer does not need to follow
changes in the ISO standard and will not work with outdated
information.")
    (license license:gpl2+)))           ; some bits use the lgpl2

(define-public iso-codes/pinned
  ;; This package should be used universally within Guix, e.g., as an input to
  ;; other Guix packages or in the Guix System installer's country selector.
  (hidden-package
   (package
     (inherit iso-codes/official)
     (source
      (origin
        (inherit (package-source iso-codes/official))
        (modules '((guix build utils)))
        (snippet
         '(begin
            (substitute* (find-files "." "\\.po$")
              (("#.*Name for TWN,.*") "")
              (("^msgid \"Taiwan, .*") "# Guix doesn't use "))
            (substitute* "data/iso_3166-1.json"
              (("(Taiwan), [^\"]*" _ name) name))))))
     (synopsis "Various ISO standards as used by GNU@tie{}Guix"))))

(define-public iso-codes
  (package
    (inherit iso-codes/pinned)
    (version "4.17.0")
    (source (origin
              (inherit (package-source iso-codes/pinned))
              (uri (git-reference
                    (url (package-home-page iso-codes/pinned))
                    (commit (string-append "v" version))))
              (file-name (git-file-name (package-name iso-codes/pinned) version))
              (sha256
               (base32
                "0a77b9aid68vakhsa3l3lx2jav5q9fp7vn50mwmzkr2lkr2l4k41"))))))

(define-public python-country-converter
  (package
    (name "python-country-converter")
    (version "1.2")
    (source
     (origin
       (method git-fetch) ;no test data in PyPI archive
       (uri (git-reference
             (url "https://github.com/IndEcol/country_converter")
             (commit (string-append "v" version))))
       (file-name (git-file-name name version))
       (sha256
        (base32 "0i1nlbahfwgx1f5q4ib32539xmc694834s0flzp0wlki0hwzd4rd"))))
    (build-system pyproject-build-system)
    (native-inputs
     (list python-pytest
           python-setuptools))
    (propagated-inputs
     (list python-pandas))
    (home-page "https://github.com/IndEcol/country_converter")
    (synopsis "Auto conversion from different country name standards")
    (description
     "The country converter (coco) automates the conversion from different
standards and version of country names.  Internally, coco is based on a table
specifying the different ISO and UN standards per country together with the
official name and a regular expression which aim to match all English versions
of a specific country name.  In addition, coco includes classification based
on UN-, EU-, OECD-membership, UN regions specifications, continents and
various MRIO and IAM databases.

Supported classification schemas: APEC, BASIC, BRIC, CC41, CIS, Cecilia 2050
classification, DACcode, EEA membership, EU membership, EXIOBASE 1
classification, EXIOBASE 2 classification, EXIOBASE 3 classification, Eora,
FAOcode, G20, G7, GBDcode, GWcode, IEA, IMAGE, IOC ISO 3166-1 alpha-2, ISO
3166-1 alpha-3, ISO 3166-1 numeric, MESSAGE 11-region classification, OECD
membership, REMIND, Schengen region, UN membership, UN numeric code, UN
region, WIOD classification, ccTLD.")
    (license license:gpl3)))

(define-public python-iso639
  (package
    (name "python-iso639")
    (version "0.4.5")
    (source
     (origin
       (method url-fetch)
       (uri (pypi-uri "iso-639" version))
       (sha256
        (base32
         "0jffmh4m20q8j27xb2fqbnlghjj0cx8pgsbzqisdg65qh2wd976w"))))
    (build-system python-build-system)
    (home-page "https://github.com/noumar/iso639")
    (synopsis "Python library for ISO 639 standard")
    (description "This package provides a Python library for ISO 639 standard
that is concerned with representation of names for languages and language
groups.")
    (license license:agpl3+)))

(define-public python-iso3166
  (package
    (name "python-iso3166")
    (version "2.1.1")
    (source
     (origin
       (method url-fetch)
       (uri (pypi-uri "iso3166" version))
       (sha256
        (base32
         "068p94gavc8gbmp5a2kw8hi5l551wfzbpmp6z7ll8sx6vnw53mgw"))))
    (build-system python-build-system)
    (home-page "https://github.com/deactivated/python-iso3166")
    (synopsis "Self-contained ISO 3166-1 country definitions")
    (description "This package provides the ISO 3166-1 country definitions.")
    (license license:expat)))
es/python-xyz.scm?id=a392ec814f44578cf231fb9f1880a663820e0f5c'>gnu: python-txaio: Update to 23.1.1....* gnu/packages/python-xyz.scm (python-txaio): Update to 23.1.1. [build-system]: Change to PYPROJECT-BUILD-SYSTEM. [propagated-inputs]: Remove. [native-inputs]: Add PYTHON-PYTEST and PYTHON-TWISTED. Marius Bakke 2023-09-22gnu: python-cachetools: Update to 5.3.1....* gnu/packages/python-xyz.scm (python-cachetools): Update to 5.3.1. * gnu/packages/matrix.scm (python-matrix-nio)[arguments]: Add phase to loosen cachetools requirement. Marius Bakke 2023-09-22gnu: python-distlib: Don't reference the implicit bash input....* gnu/packages/python-xyz.scm (python-distlib)[inputs]: Add BASH-MINIMAL. [arguments]: Use SEARCH-INPUT-FILE instead of WHICH. Marius Bakke 2023-09-22gnu: python-distlib: Update to 0.3.7....* gnu/packages/python-xyz.scm (python-distlib): Update to 0.3.7. [build-system]: Switch to PYPROJECT-BUILD-SYSTEM. [arguments]: Remove redundant phases. [native-inputs]: Remove PYTHON-PYPA-BUILD. Marius Bakke 2023-09-22gnu: python-platformdirs: Update to 3.10.0....* gnu/packages/python-xyz.scm (python-platformdirs): Update to 3.10.0. [build-system]: Switch to PYPROJECT-BUILD-SYSTEM. [native-inputs]: Add PYTHON-HATCHLING and PYTHON-HATCH-VCS. Remove PYTHON-SETUPTOOLS-SCM. Marius Bakke 2023-09-22gnu: python-bleach: Update to 6.0.0....* gnu/packages/python-xyz.scm (python-bleach): Update to 6.0.0. [propagated-inputs]: Remove PYTHON-WEBENCODINGS. Marius Bakke 2023-09-22gnu: python-pkginfo: Update to 1.9.6....* gnu/packages/python-xyz.scm (python-pkginfo): Update to 1.9.6. [build-system]: Switch to PYPROJECT-BUILD-SYSTEM. [native-inputs]: Remove PYTHON-WHEEL. Add PYTHON-PYTEST. Marius Bakke 2023-09-22gnu: python-daemon: Update to 3.0.1....* gnu/packages/python-xyz.scm (python-daemon): Update to 3.0.1. [arguments]: Skip two more tests. [propagated-inputs]: Add PYTHON-PACKAGING and PYTHON-SETUPTOOLS. [native-inputs]: Remove PYTHON-COVERAGE, PYTHON-TWINE, and PYTHON-MOCK. Marius Bakke 2023-09-22gnu: python-deprecated: Update to 1.2.14....* gnu/packages/python-xyz.scm (python-deprecated): Update to 1.2.14. Marius Bakke 2023-09-22gnu: python-flex: Update to 6.14.1....* gnu/packages/python-xyz.scm (python-flex): Update to 6.14.1. [propagated-inputs]: Remove PYTHON-ISO8601. Add PYTHON-STRICT-RFC3339. Marius Bakke 2023-09-22gnu: Add python-towncrier....* gnu/packages/python-xyz.scm (python-towncrier): New variable. Marius Bakke 2023-09-22gnu: Add python-pyproject-hooks....* gnu/packages/python-xyz.scm (python-pyproject-hooks): New variable. Marius Bakke 2023-09-22gnu: Add python-tracerite....* gnu/packages/python-xyz.scm (python-tracerite): New variable. Marius Bakke 2023-09-22gnu: python-deprecated: Remove unused inputs....* gnu/packages/python-xyz.scm (python-deprecated): Remove PYTHON-SPHINX and PYTHON-TOX. Marius Bakke 2023-09-22gnu: python-filelock: Update home page....* gnu/packages/python-xyz.scm (python-filelock)[home-page]: Follow redirect. Marius Bakke 2023-09-22gnu: Add python-dirty-equals....* gnu/packages/python-xyz.scm (python-dirty-equals): New variable. Marius Bakke 2023-09-21gnu: python-bashlex: Update to 0.18....* gnu/packages/python-xyz.scm (python-bashlex): Update to 0.18. This fixes the build. Clément Lassieur 2023-09-19gnu: Add python-benchmark-4dn....* gnu/packages/python-xyz.scm (python-benchmark-4dn): New variable. Ricardo Wurmus 2023-09-18gnu: python-fit-nbinom: Remove syntax error in setup.py....* gnu/packages/python-xyz.scm (python-fit-nbinom)[arguments]: Add phase 'remove-invalid-syntax. Signed-off-by: Ricardo Wurmus <rekado@elephly.net> Mădălin Ionel Patrașcu 2023-09-16gnu: python-typeguard: Add dependency on python-setuptools-scm....* gnu/packages/python-xyz.scm (python-typeguard)[native-inputs]: Add python-setuptools-scm. Vinicius Monego 2023-09-14gnu: python-cython: Support building on the Hurd....* gnu/packages/python-xyz.scm (python-cython)[arguments]: In phase `check', skip failing tests on the Hurd. Janneke Nieuwenhuizen 2023-09-13gnu: python-qtsass: Update to 0.4.0....This also fixes test failures preventing the package from building. * gnu/packages/python-xyz.scm (python-qtsass): Update to 0.4.0, fix build. [native-inputs]: Add python-flaky. Signed-off-by: Christopher Baines <mail@cbaines.net> Sharlatan Hellseher 2023-09-13gnu: python-libsass: Update to 0.22.0....* gnu/packages/python-xyz.scm (python-libsass): Update to 0.22.0. [phases]: Add new phase 'silent-failing-tests and disable 2 failing tests to complete build. Signed-off-by: Christopher Baines <mail@cbaines.net> Sharlatan Hellseher 2023-09-08gnu: python-bitarray: Update to 2.8.1....* gnu/packages/python-xyz.scm (python-bitarray): Update to 2.8.1. Marius Bakke 2023-09-08gnu: python-fasteners: Update to 0.17.3....* gnu/packages/python-xyz.scm (python-fasteners): Update to 0.17.3. [build-system]: Switch to pyproject-build-system. [arguments]: Add custom 'check phase. [propagated-inputs]: Remove python-monotonic and python-six. [native-inputs]: Remove python-testtools; add python-diskcache, python-more-itertools, and python-pytest. Efraim Flashner 2023-09-08gnu: python-numcodecs: Fix building on non x86 machines....* gnu/packages/python-xyz.scm (python-numcodecs)[source]: Adjust snippet to prevent setup.py adding unsupported architecture specific CFLAGS. Efraim Flashner 2023-09-08gnu: python-numcodecs: Remove another cythonized file....* gnu/packages/python-xyz.scm (python-numcodecs)[source]: Remove another cythonized file. Efraim Flashner 2023-09-08gnu: Remove python-pyflakes-2.2....* gnu/packages/python-xyz.scm (python-pyflakes-2.2): Delete variable. * gnu/packages/patches/python-pyflakes-test-location.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it. Efraim Flashner 2023-09-08gnu: Remove python-pycodestyle-2.6....* gnu/packages/python-xyz.scm (python-pycodestyle-2.6): Delete variable. Efraim Flashner 2023-09-08gnu: Remove python-flake8-3.8....* gnu/packages/python-xyz.scm (python-flake8-3.8): Delete variable. Efraim Flashner 2023-09-08gnu: python-eventlet: Update to 0.33.3....* gnu/packages/python-xyz.scm (python-eventlet): Update to 0.33.3. [propagated-inputs]: Remove python-monotonic. [arguments]: Skip another test. Efraim Flashner 2023-09-08gnu: python-pyspnego: Update to 0.8.0....* gnu/packages/python-xyz.scm (python-pyspnego): Update to 0.8.0. [source]: Download from pypi. [arguments]: Remove custom 'check phase. [build-system]: Switch to pyproject-build-system. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> c4droid