aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
e
2023-03-07services: ladspa: Export accessors....Bruno Victal
2023-03-07services: alsa: Export accessors....Bruno Victal
2023-03-07services: pulseaudio: Export accessors....Bruno Victal
mode:
authorMarius Bakke <marius@gnu.org>2023-09-10 15:02:23 +0800
committerMarius Bakke <marius@gnu.org>2023-09-22 01:29:20 +0800
commitc08b919b67dc1a0b1e6e537bdc19a4b19b8dc84a (patch)
tree38effa1a673037e904a61e415a165ca796c4e031 /gnu/packages/python-xyz.scm
parent9d285c8bebc714bc757f889f1509932a8f485849 (diff)
downloadguix-c08b919b67dc1a0b1e6e537bdc19a4b19b8dc84a.tar.gz
guix-c08b919b67dc1a0b1e6e537bdc19a4b19b8dc84a.zip
gnu: python-distlib: Update to 0.3.7.
* gnu/packages/python-xyz.scm (python-distlib): Update to 0.3.7. [build-system]: Switch to PYPROJECT-BUILD-SYSTEM. [arguments]: Remove redundant phases. [native-inputs]: Remove PYTHON-PYPA-BUILD.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm26
1 files changed, 7 insertions, 19 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0426220ef2..b574ec2efe 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8537,42 +8537,30 @@ and therefore easier to read and write.")
(define-public python-distlib
(package
(name "python-distlib")
- (version "0.3.5")
+ (version "0.3.7")
(source
(origin
(method url-fetch)
(uri (pypi-uri "distlib" version))
(sha256
(base32
- "1zmjraasgqkz0gfv4mc4w4fj4k2fxj62h1pf5dgb5qqbqwvmgxx7"))))
- (build-system python-build-system)
+ "1a27f5p93j9i1l3324qgahs3g8ai91fmx783jpyyla506i5ybbwx"))))
+ (build-system pyproject-build-system)
(arguments
(list
#:phases
#~(modify-phases %standard-phases
- (replace 'build
- (lambda _
- ;; ZIP does not support timestamps before 1980.
- (setenv "SOURCE_DATE_EPOCH" "315532800")
- (invoke "python" "-m" "build" "--wheel" "--no-isolation" ".")))
(add-before 'build 'no-/bin/sh
(lambda _
(substitute* '("distlib/scripts.py" "tests/test_scripts.py")
(("/bin/sh") (which "sh")))))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
+ (add-before 'check 'prepare-test-environment
+ (lambda _
(setenv "HOME" "/tmp")
;; NOTE: Any value works, the variable just has to be present.
- (setenv "SKIP_ONLINE" "1")
- (when tests?
- (invoke "pytest" "-vv"))))
- (replace 'install
- (lambda _
- (let ((whl (car (find-files "dist" "\\.whl$"))))
- (invoke "pip" "--no-cache-dir" "--no-input"
- "install" "--no-deps" "--prefix" #$output whl)))))))
+ (setenv "SKIP_ONLINE" "1"))))))
(native-inputs
- (list python-pypa-build python-pytest))
+ (list python-pytest))
(home-page "https://github.com/pypa/distlib")
(synopsis "Distribution utilities")
(description "Distlib is a library which implements low-level functions that