aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2023-09-11 17:35:31 +0800
committerMarius Bakke <marius@gnu.org>2023-09-22 01:29:19 +0800
commit977dbf25889d995595d2a9d82a497117fc9afb91 (patch)
tree4b8206482542a31b17788a3d1f7bdd3f01801d77 /gnu/packages/python-xyz.scm
parent9d87b400a699f5d1ca4a303817549733b73dba1e (diff)
downloadguix-977dbf25889d995595d2a9d82a497117fc9afb91.tar.gz
guix-977dbf25889d995595d2a9d82a497117fc9afb91.zip
gnu: python-daemon: Update to 3.0.1.
* gnu/packages/python-xyz.scm (python-daemon): Update to 3.0.1. [arguments]: Skip two more tests. [propagated-inputs]: Add PYTHON-PACKAGING and PYTHON-SETUPTOOLS. [native-inputs]: Remove PYTHON-COVERAGE, PYTHON-TWINE, and PYTHON-MOCK.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm25
1 files changed, 11 insertions, 14 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f42b605421..ffe4ecf5c1 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5625,38 +5625,35 @@ logging and tracing of the execution.")
(define-public python-daemon
(package
(name "python-daemon")
- (version "2.3.0")
+ (version "3.0.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "python-daemon" version))
(sha256
(base32
- "1bxfn2bq56sd4w0nm9mqy8y0905m7fc8vmhnjxlrf49vcbqr7adx"))))
+ "1rfsnij687hk97ppzs2q6mwmxgr632nh672ajd0gzsppf8ilamvc"))))
(build-system python-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
(add-before 'check 'adjust-tests
(lambda _
- ;; Drop use of testtools.helpers.safe_hasattr which has
- ;; been removed in favor of hasattr.
- (substitute* "test/test_metadata.py"
- (("testtools\\.helpers\\.safe_hasattr")
- "hasattr"))
;; FIXME: Determine why test fails
(substitute* "test/test_daemon.py"
(("test_detaches_process_context")
- "skip_test_detaches_process_context")))))))
+ "skip_test_detaches_process_context"))
+ (substitute* "test/scaffold.py"
+ (("test_exception_instance")
+ "skip_test_exception_instance")
+ (("test_exception_types")
+ "skip_test_exception_types")))))))
(propagated-inputs
- (list python-lockfile))
+ (list python-lockfile python-packaging python-setuptools))
(native-inputs
- (list python-coverage
- python-testtools
+ (list python-docutils
python-testscenarios
- python-twine
- python-mock
- python-docutils))
+ python-testtools))
(home-page "https://pagure.io/python-daemon/")
(synopsis "Python library for making a Unix daemon process")
(description "Python-daemon is a library that assists a Python program to