aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages augeas)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix gexp)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix git-download)
  #:use-module (guix utils)
  #:use-module (guix build-system gnu)
  #:use-module (guix build-system pyproject)
  #:use-module (gnu packages)
  #:use-module (gnu packages check)
  #:use-module (gnu packages libffi)
  #:use-module (gnu packages readline)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages xml))

(define-public augeas
  (package
    (name "augeas")
    (version "1.14.1")
    (source (origin
              ;; XXX: Project release has moved to GitHub which has
              ;;      pre-generated "configure" script that allows to simplify
              ;;      the package definition. Try to completely build from
              ;;      source, glibc comes as git submodule.
              (method url-fetch)
              (uri
               (string-append
                "https://github.com/hercules-team/augeas/releases/download/"
                "release-" version
                "/augeas-" version ".tar.gz"))
              (sha256
               (base32
                "1zzdp5bwnszza5q6cjw66hkicay8b49n5pda7cbcgfg4hbbzv2rn"))))
    (build-system gnu-build-system)
    (propagated-inputs
     (list libxml2))
    (native-inputs
     (list readline pkg-config))
    (home-page "https://augeas.net")
    (synopsis "Edit configuration files programmatically")
    (description
     "Augeas is a library and command line tool for programmatically editing
configuration files in a controlled manner.  Augeas exposes a tree of all
configuration settings and a simple local API for manipulating the tree.
Augeas then modifies underlying configuration files according to the changes
that have been made to the tree; it does as little modeling of configurations
as possible, and focuses exclusivley on transforming the tree-oriented syntax
of its public API to the myriad syntaxes of individual configuration files.")
    (license license:lgpl2.1+)))

(define-public python-augeas
  (package
    (name "python-augeas")
    (version "1.2.0")
    (source
     (origin
       (method git-fetch)
       (uri (git-reference
             (url "https://github.com/hercules-team/python-augeas")
             (commit (string-append "v" version))))
       (file-name (git-file-name name version))
       (sha256
        (base32 "1l17gl23f5naram1jaab7gjr9bhjdj97fd9sydvs7cmpns91rbrf"))))
    (build-system pyproject-build-system)
    (native-inputs
     (list python-pytest pkg-config))
    (propagated-inputs
     (list python-cffi))
    (inputs
     (list augeas libxml2))
    (home-page "https://github.com/hercules-team/python-augeas")
    (synopsis "Python bindings for Augeas")
    (description "Pure Python bindings for @url{https://augeas.net, Augeas}.")
    (license license:lgpl2.1+)))
>2024-07-27gnu: klee: Wrap klee-stats for Python dependencies....* gnu/packages/check.scm (klee): Wrap klee-stats. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> Sören Tempel 2024-07-25gnu: go-github-com-google-go-cmp-cmp: Rename variable....* gnu/packages/golang.scm (go-github-com-google-go-cmp-cmp): Rename variable to go-github-com-google-go-cmp, which reflects go.mod import path and improves importer performance. (go-github-com-zclconf-go-cty, go-golang-org-x-vuln, go-google-golang-org-protobuf, go-gotest-tools-assert, go-gotest-tools-internal-source, go-gotest-tools-internal-format, gofumpt, gopls, gotestsum): Swap go-github-com-google-go-cmp-cmp to go-github-com-google-go-cmp in inputs, propagated-inputs or native-inputs. * gnu/packages/golang-check.scm (go-github-com-frankban-quicktest, go-github-com-google-go-cmdtest): Likewise. * gnu/packages/golang-web.scm (go-github-com-aws-aws-sdk-go-v2, go-github-com-aws-aws-sdk-go-v2-config, go-github-com-aws-smithy-go, go-github-com-go-jose-go-jose-v3, go-github-com-makeworld-the-better-one-go-gemini, go-golang-org-x-oauth2, go-gopkg-in-square-go-jose-v2): Likewise. * gnu/packages/golang-xyz.scm (go-github-com-goccy-go-yaml): Likewise. * gnu/packages/check.scm (actionlint): Likewise. * gnu/packages/databases.scm (sqls): Likewise. * gnu/packages/ipfs.scm (go-github-com-ipld-go-ipld-prime, go-github-com-whyrusleeping-cbor-gen): Likewise. * gnu/packages/web.scm (go-github-com-itchyny-gojq): Likewise. Change-Id: Ie6eeba936f7da404d70fbbaad34f5b43aec4e05b Sharlatan Hellseher 2024-07-21gnu: rapidcheck: Disable failing tests on aarch64....* gnu/packages/check.scm (rapidcheck): Disable failing tests on aarch64. Change-Id: I9b4e7be2acad615cc1586adb37cc39b43590b2d8 Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> Roman Scherer 2024-07-13gnu: klee: Build with klee-uclibc support....* gnu/packages/check.scm (klee): Use klee-uclibc. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> Sören Tempel 2024-07-13gnu: Add klee-uclibc....* gnu/packages/check.scm (klee-uclibc): New variable. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> Sören Tempel 2024-07-13gnu: rapidcheck: Update to 0.0.0-1.ff6af6f....* gnu/packages/check.scm (rapidcheck): Update to 0.0.0-1.ff6af6f. [source]: Add snippet to find inputs. [arguments]: Remove #:phases and #:tests?. <#:configure-flags?>: Add “-DRC_ENABLE_BOOST=on”, “-DRC_ENABLE_CATCH=on”, “-DRC_ENABLE_DOCTEST=on”, “-DRC_ENABLE_GTEST=on”, and “-DRC_ENABLE_TESTS=on”. [inputs]: Add boost, catch2, doctest and googletest. [native-inputs]: Add catch2 and googletest. Liliana Marie Prikler 2024-06-29gnu: Remove go-golang.org-x-sync-semaphore....* gnu/packages/golang-build.scm (go-golang.org-x-sync-semaphore): Delete variable. * gnu/packages/check.scm (actionlint): Adjust inputs. [inputs]: Remove go-golang.org-x-sync-semaphore. * gnu/packages/version-control.scm (git-lfs): Likewise. [propagated-inputs]: Remove go-golang.org-x-sync-semaphore; add go-golang-org-x-sync. Change-Id: Icf3edfc46696c8b9af79787ff77f7e65852bfef4 Sharlatan Hellseher 2024-06-29gnu: Remove go-golang.org-x-sync-errgroup....* gnu/packages/golang-build.scm (go-golang.org-x-sync-errgroup): Delete variable. * gnu/packages/check.scm (actionlint): Adjust inputs. [inputs]: Remove go-golang.org-x-sync-errgroup; add go-golang-org-x-sync. * gnu/packages/golang.scm (gotestsum): Likewise. [native-inputs]: Remove go-golang.org-x-sync-errgroup; add go-golang-org-x-sync. * gnu/packages/golang.scm (go-github-com-prometheus-procfs): Likewise. [propagated-inputs]: Remove go-golang.org-x-sync-errgroup; add go-golang-org-x-sync. * gnu/packages/terminals.scm (go-github-com-junegunn-fzf): Likewise. [inputs]: Remove go-golang.org-x-sync-errgroup; add go-golang-org-x-sync. * gnu/packages/version-control.scm (ghq): Likewise. [inputs]: Remove go-golang.org-x-sync-errgroup; add go-golang-org-x-sync. Change-Id: If64c30da47ed9cd043798f427f2927b76394f3c4 Sharlatan Hellseher 2024-06-23gnu: Add klee....* gnu/packages/check.scm (klee): New variable. Liliana Marie Prikler 2024-04-22gnu: Add python-pytest-next....* gnu/packages/check.scm (python-pytest-next): New variable. Nicolas Graves 2024-04-22gnu: python-pytest-xdist: Use pyproject-build-system....* gnu/packages/check.scm (python-pytest-xdist): Use pyproject-build-system. Nicolas Graves 2024-04-06gnu: go-github-com-mattn-go-runewidth: Move to golang-xyz....* gnu/packages/golang.scm (go-github-com-mattn-go-runewidth): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. * gnu/packages/check.scm: Add (gnu packages golang-xyz) module. * gnu/packages/disk.scm: Likewise. * gnu/packages/messaging.scm: Likewise. * gnu/packages/time.scm: Likewise. * gnu/packages/weather.scm: Likewise. Change-Id: I80f8b4c31c0fd8fee7c190a7740513ee139646d4 Sharlatan Hellseher 2024-03-29gnu: Add python-pytest-examples....* gnu/packages/check.scm (python-pytest-examples): New variable. Change-Id: I8199a7d7294c3b04134474f9f116468ac327cba8 Sharlatan Hellseher 2024-03-29gnu: Add python-nose-exclude....* gnu/packages/check.scm (python-nose-exclude): New variable. Change-Id: I5c91b682163890c822f7d4a548e92fdd287d78a2 Sharlatan Hellseher 2024-03-27gnu: Add python-pytest-relaxed....* gnu/packages/check.scm (python-pytest-relaxed): New variable. Change-Id: I9c506fe6a6586c87d72775a0567fd3c45ba03568 Signed-off-by: Ricardo Wurmus <rekado@elephly.net> nafkhamdc 2024-03-10gnu: check-0.14: Fix build on powerpc-linux....* gnu/packages/check.scm (check-0.14)[source]: Include patch from check. Change-Id: I490b3d4cbe09381d091a398614d6b55687ac758f Efraim Flashner 2024-03-09gnu: catch2-3: Update to 3.5.3....* gnu/packages/check.scm (catch2-3): Update to 3.5.3. [arguments]: Remove -DCMAKE_CXX_FLAGS from configure-flags. Change-Id: Ib9e88dd6071d14ef70177fa83964a5d92b916ac0 Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Zheng Junjie 2024-03-02gnu: Add theft....* gnu/packages/check.scm (theft): New variable. Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Liliana Marie Prikler 2024-03-02gnu: Add greatest....* gnu/packages/check.scm (greatest): New variable. Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Liliana Marie Prikler 2024-02-27gnu: googlebenchmark: Update to 1.8.3....* gnu/packages/check.scm (googlebenchmark): Update to 1.8.3. Change-Id: I7fb761304e180f5b1cd5031a970909fba2dca1d7 Signed-off-by: Ludovic Courtès <ludo@gnu.org> Greg Hogan 2024-02-17gnu: Add python-pytest-tornado5....* gnu/packages/check.scm (python-pytest-tornado5): New variable. Change-Id: I9843e91d750bf17128eb6f566b8dbb5cbc0d8278 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Giacomo Leidi 2024-02-13gnu: go-golang.org-x-sync-errgroup: Move to golang-build....* gnu/packages/golang.scm (go-golang.org-x-sync-errgroup, go-golang.org-x-sync-semaphore): Move from here ... * gnu/packages/golang-build.scm: ... to here. * gnu/packages/check.scm: Add (gnu packages golang-build) module. Change-Id: Ie886c0f44e0a70629e23371b447f5a35006ade21 Sharlatan Hellseher 2024-01-28gnu: go-github.com-smartystreets-goconvey: Move to (gnu packages golang-check)....* gnu/packages/check.scm (go-github.com-smartystreets-goconvey): Move from here ... * gnu/packages/golang-check.scm: ... to here. Change-Id: I19d8db6e3b07e1d165396c0498e328b70b2cc760 Sharlatan Hellseher 2024-01-28gnu: go-github.com-smartystreets-assertions: Move to (gnu packages golang-che......* gnu/packages/check.scm (go-github.com-smartystreets-assertions): Move from here ... * gnu/packages/golang-check.scm: ... to here. Change-Id: Ia90bbe984fe19dd48d9df91364a7ecf2bf8bd37f Sharlatan Hellseher 2024-01-28gnu: go-github.com-smartystreets-gunit: Move to (gnu packages golang-check)....* gnu/packages/check.scm (go-github.com-smartystreets-gunit): Move from here ... * gnu/packages/golang-check.scm: ... to here. Change-Id: I7204e118f99064027f0e10838d2b44fee212d21d Sharlatan Hellseher 2024-01-23gnu: python-nose2: Update to 0.14.0....* gnu/packages/check.scm (python-nose2): Update to 0.14.0. [native-inputs]: Remove python-coverage. [propagated-inputs]: Remove python-six. Change-Id: I15a30723fe49cca9929524e543d12c9e2f4b02ca Ricardo Wurmus 2024-01-16gnu: Add python-pytest-nunit....* gnu/packages/check.scm (python-pytest-nunit): New variable. Change-Id: Ic67c973460f09b15bf683f70040a3f5e4381108d Ricardo Wurmus 2024-01-13gnu: check2: Fix tests on i686-linux....Reported upstream to <https://github.com/catchorg/Catch2/issues/2796>. It is expected that SSE2 is enabled for i686 builds or tests fail. * gnu/packages/check.scm (check2)[arguments]: Enable SSE2 for x86_64-linux and i686-linux in configure-flags. Co-authored-by: Richard Sent <richard@freakingpenguin.com> Co-authored-by: Jo Gay <@jane.lx.gay> Change-Id: I99205f92b66ab3d10affbfb58918f37069ba82ec John Kehayias 2024-01-09gnu: catch2-3: Update to 3.5.1....* gnu/packages/check.scm (catch2-3.3): Rename to... (catch2-3): ... this. Update to 3.5.1. * gnu/packages/logging.scm (spdlog) [native-inputs]: Rename catch2-3.3 to catch2-3. * gnu/packages/potassco.scm (clingo) [inputs]: Likewise. Change-Id: Ied7724597ff4c6371dc4fedc10452ae870d23933 Maxim Cournoyer 2024-01-09gnu: Add python-pytest-dotenv....* gnu/packages/check.scm (python-pytest-dotenv): New variable. Troy Figiel 2024-01-03gnu: actionlint: Update to 1.6.26....* gnu/packages/check.scm (actionlint): Update to 1.6.26. [inputs]: Swap go-github-com-robfig-cron-1.2 to go-github-com-robfig-cron * gnu/packages/golang.scm (go-github-com-robfig-cron-1.2): Delete variable. Change-Id: Ie2c25254ffefb99f8808f74ae4a9d85bbbcb6437 Sharlatan Hellseher 2023-12-05gnu: python-setuptools-lint: Add missing input....* gnu/packages/check.scm (python-setuptools-lint)[propagated-inputs]: Add python-tomli. Change-Id: I0ab7d3b129d6c347c212b968c4aeb425e3ee97ae Efraim Flashner 2023-12-02gnu: python-lit: Update to 17.0.6....* gnu/packages/check.scm (python-lit): Update to 17.0.6. [native-inputs]: Remove llvm-14; add llvm. Change-Id: I45ccc5302c2481b82f26201e66994e15eeaecc9d Efraim Flashner 2023-11-18gnu: python-pytest-perf: Update to 0.13.1....* gnu/packages/check.scm (python-pytest-perf): Update to 0.13.1. [build-system]: Switch to pyproject-build-system, because setup.py has been removed since 0.12.1. [arguments]<#:phases>: Remove ignored tests from the check phase. <#:test-flags>: And use test flags instead. Change-Id: Id81e47666a51b411740c6e6a6f6976cee616b6a4 Troy Figiel 2023-10-14gnu: guile-proba: Fix environment vars in Guile Proba's script....* gnu/packages/check.scm (guile-proba): Micro fix. Guile Proba's CLI script, as created via Guix's `wrap-program', should take into account (as opposed to discard) the original, user-defined values of `GUILE_LOAD_PATH' and `GUILE_LOAD_COMPILED_PATH'. Currently, Guile Proba's CLI script is unable to find any third-party library needed by the app being tested. This micro change should fix this. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> Fabio Natali 2023-10-11gnu: guile-proba: Update to 0.3.1....* gnu/packages/check.scm (guile-proba): Update to 0.3.1. Signed-off-by: Christopher Baines <mail@cbaines.net> Change-Id: I7cc9708078fee14723eec90e4ce45d2beb3a01d0 Fabio Natali