aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorTaneli Hukkinen <hukkinj1@users.noreply.github.com>2021-02-09 23:10:30 +0200
committerGitHub <noreply@github.com>2021-02-09 15:10:30 -0600
commitf0b4fd40fc4431329754b3be3cec0630827df98c (patch)
tree88048b69dff067a1d860ef599c0464e355f97089 /setup.py
parent1282379d831ccc4306345fc7fcd09a0026694074 (diff)
downloadimmutables-f0b4fd40fc4431329754b3be3cec0630827df98c.tar.gz
immutables-f0b4fd40fc4431329754b3be3cec0630827df98c.zip
Fix flake8 errors and add it to CI (#45)
* Fix flake8 errors and add it to CI * Use extras for test dependencies Co-authored-by: Fantix King <fantix.king@gmail.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py14
1 files changed, 14 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 590ad41..ba8e1da 100644
--- a/setup.py
+++ b/setup.py
@@ -3,6 +3,19 @@ import platform
import setuptools
+# Minimal dependencies required to test immutables.
+TEST_DEPENDENCIES = [
+ # pycodestyle is a dependency of flake8, but it must be frozen because
+ # their combination breaks too often
+ # (example breakage: https://gitlab.com/pycqa/flake8/issues/427)
+ 'flake8~=3.8.4',
+ 'pycodestyle~=2.6.0',
+]
+
+EXTRA_DEPENDENCIES = {
+ 'test': TEST_DEPENDENCIES,
+}
+
CFLAGS = ['-O2']
if platform.uname().system != 'Windows':
CFLAGS.extend(['-std=c99', '-fsigned-char', '-Wall',
@@ -73,4 +86,5 @@ setuptools.setup(
provides=['immutables'],
include_package_data=True,
ext_modules=ext_modules,
+ extras_require=EXTRA_DEPENDENCIES,
)