aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorElvis Pranskevichus <elvis@magic.io>2020-04-22 17:58:50 -0700
committerElvis Pranskevichus <elvis@magic.io>2020-04-22 18:07:53 -0700
commit60252260070137dd75f09d99a50c5dc624dea439 (patch)
treea6296dd37ef00286a1d0945812ed77276759516d /setup.py
parentd107c3ea800d206ef890cafa81a8520aa29c5eb1 (diff)
downloadimmutables-60252260070137dd75f09d99a50c5dc624dea439.tar.gz
immutables-60252260070137dd75f09d99a50c5dc624dea439.zip
Define NDEBUG actively
`NDEBUG` is not defined by the standard library or the compiler by default, so make sure it's defined when building non-debug builds.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 6 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 3749742..a30fc5d 100644
--- a/setup.py
+++ b/setup.py
@@ -18,20 +18,23 @@ with open(os.path.join(
break
else:
raise RuntimeError(
- 'unable to read the version from immutables/__init__.py')
+ 'unable to read the version from immutables/_version.py')
if platform.python_implementation() == 'CPython':
if os.environ.get("DEBUG_IMMUTABLES") == '1':
- undef_macros = ["NDEBUG"]
+ define_macros = []
+ undef_macros = ['NDEBUG']
else:
- undef_macros = None
+ define_macros = [('NDEBUG', '1')]
+ undef_macros = []
ext_modules = [
setuptools.Extension(
"immutables._map",
["immutables/_map.c"],
extra_compile_args=CFLAGS,
+ define_macros=define_macros,
undef_macros=undef_macros)
]
else: