aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorYury Selivanov <yury@magic.io>2018-04-03 21:51:29 -0400
committerYury Selivanov <yury@magic.io>2018-04-03 21:51:29 -0400
commit40495427c5b1c6f42faec5b4b6418228aa6247c6 (patch)
treea89763a01883635c6da3517f0f8b8125281776a1 /setup.py
parent0753873a6d199e133b1410e64829746c12dec32f (diff)
downloadimmutables-40495427c5b1c6f42faec5b4b6418228aa6247c6.tar.gz
immutables-40495427c5b1c6f42faec5b4b6418228aa6247c6.zip
setup: Add long_description
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 5 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 40877c0..308083e 100644
--- a/setup.py
+++ b/setup.py
@@ -32,10 +32,15 @@ else:
ext_modules = []
+with open(os.path.join(os.path.dirname(__file__), 'README.rst')) as f:
+ readme = f.read()
+
+
setuptools.setup(
name='immutables',
version=VERSION,
description='Immutable Collections',
+ long_description=readme,
classifiers=[
'License :: OSI Approved :: Apache Software License',
'Intended Audience :: Developers',
@@ -45,7 +50,6 @@ setuptools.setup(
'Operating System :: MacOS :: MacOS X',
'Operating System :: Microsoft :: Windows',
],
- platforms=['POSIX'],
author='MagicStack Inc',
author_email='hello@magic.io',
url='https://github.com/MagicStack/immutables',