aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorBryan Forbes <bryan@reigndropsfall.net>2021-02-10 14:37:35 -0600
committerElvis Pranskevichus <elvis@magic.io>2021-08-03 17:54:57 -0700
commit39f9f0de168b0149456a1aca09ef3f442f436bbf (patch)
tree785d7d9d9543c78e38019ced2f648d492f6adf6b /setup.py
parent67c5edfb8284e39ab6a0be9a4644ede306c6e9bd (diff)
downloadimmutables-39f9f0de168b0149456a1aca09ef3f442f436bbf.tar.gz
immutables-39f9f0de168b0149456a1aca09ef3f442f436bbf.zip
Refactor typings
* Improve typing of `__init__()` * Update typing of `Map`-producing functions to produce the correct type * Update typing of other methods to more closely align with `Mapping` * Add protocol classes for unexposed data structures * Export protocol classes for ease of use in typed code * Update stub file to pass in mypy strict mode
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index ba8e1da..530013c 100644
--- a/setup.py
+++ b/setup.py
@@ -10,6 +10,7 @@ TEST_DEPENDENCIES = [
# (example breakage: https://gitlab.com/pycqa/flake8/issues/427)
'flake8~=3.8.4',
'pycodestyle~=2.6.0',
+ 'mypy>=0.800',
]
EXTRA_DEPENDENCIES = {
@@ -86,5 +87,6 @@ setuptools.setup(
provides=['immutables'],
include_package_data=True,
ext_modules=ext_modules,
+ install_requires=['typing-extensions>=3.7.4.3;python_version<"3.8"'],
extras_require=EXTRA_DEPENDENCIES,
)