aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorElvis Pranskevichus <elvis@edgedb.com>2021-08-06 18:19:23 -0700
committerGitHub <noreply@github.com>2021-08-06 18:19:23 -0700
commit189b959d2e5f09660508482398414e2869c074ff (patch)
tree6497a6619384ee204f30d05c9ee6d3393fc96e8c /setup.py
parentfa355239e70411179c70b16ed4ff7113d8008dad (diff)
downloadimmutables-189b959d2e5f09660508482398414e2869c074ff.tar.gz
immutables-189b959d2e5f09660508482398414e2869c074ff.zip
Drop Python 3.5 support declaration, add Python 3.10 (#71)
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index b21c05a..221313a 100644
--- a/setup.py
+++ b/setup.py
@@ -65,16 +65,16 @@ setuptools.setup(
version=VERSION,
description='Immutable Collections',
long_description=readme,
- python_requires='>=3.5',
+ python_requires='>=3.6',
classifiers=[
'License :: OSI Approved :: Apache Software License',
'Intended Audience :: Developers',
'Programming Language :: Python :: 3 :: Only',
- 'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: 3.8',
'Programming Language :: Python :: 3.9',
+ 'Programming Language :: Python :: 3.10',
'Operating System :: POSIX',
'Operating System :: MacOS :: MacOS X',
'Operating System :: Microsoft :: Windows',