aboutsummaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorElvis Pranskevichus <elvis@edgedb.com>2021-08-07 15:26:11 -0700
committerElvis Pranskevichus <elvis@edgedb.com>2021-08-07 15:28:55 -0700
commit88e2427ed1f4d9d396dafc928ae09f2319c08828 (patch)
tree62d393b1f4517abcc5f7ad56977f13e38a512788 /pyproject.toml
parent07279182486b3c2522a9b3c5d9ca8488545a8ee9 (diff)
downloadimmutables-88e2427ed1f4d9d396dafc928ae09f2319c08828.tar.gz
immutables-88e2427ed1f4d9d396dafc928ae09f2319c08828.zip
Consolidate mypy and pytest config into pyproject.toml
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml18
1 files changed, 18 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 810162d..de2ece5 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -4,3 +4,21 @@ requires-python = ">=3.6"
[build-system]
requires = ["setuptools>=42", "wheel"]
build-backend = "setuptools.build_meta"
+
+[tool.pytest.ini_options]
+minversion = "6.0"
+addopts = "--capture=no --assert=plain --strict-markers --tb=native --import-mode=importlib"
+testpaths = "tests"
+filterwarnings = "default"
+
+[tool.mypy]
+incremental = true
+strict = true
+
+[[tool.mypy.overrides]]
+module = "immutables.map"
+ignore_errors = true
+
+[[tool.mypy.overrides]]
+module = "immutables._testutils"
+ignore_errors = true