aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWojtek Kosior <koszko@koszko.org>2022-07-08 19:09:50 +0200
committerWojtek Kosior <koszko@koszko.org>2022-07-09 09:03:50 +0200
commit96fca118960d3d5d6e40e00bcc85307a001f75e2 (patch)
treec3354d2f01820eb8edb19e073ba893e6671d9837
parente55faf7dd0c13af4c4eaf94ebe0f2ae18799898a (diff)
downloadimmutables-debian-debian.tar.gz
immutables-debian-debian.zip
update debian/patchesdebian-debian
-rw-r--r--debian/patches/0001-add-mypy.ini-for-older-mypy-versions-that-don-t-supp.patch22
-rw-r--r--debian/patches/0002-ensure-uniform-quoting-in-mypy-test-messages.patch20
-rw-r--r--debian/patches/0003-remove-asterisks-used-to-mark-inferred-types-under-c.patch19
-rw-r--r--debian/patches/series3
4 files changed, 64 insertions, 0 deletions
diff --git a/debian/patches/0001-add-mypy.ini-for-older-mypy-versions-that-don-t-supp.patch b/debian/patches/0001-add-mypy.ini-for-older-mypy-versions-that-don-t-supp.patch
new file mode 100644
index 0000000..ef9ea28
--- /dev/null
+++ b/debian/patches/0001-add-mypy.ini-for-older-mypy-versions-that-don-t-supp.patch
@@ -0,0 +1,22 @@
+From: Wojtek Kosior <koszko@koszko.org>
+Date: Fri, 8 Jul 2022 19:08:15 +0200
+Subject: add mypy.ini for older mypy versions that don't support
+ pyproject.toml
+
+---
+ mypy.ini | 6 ++++++
+ 1 file changed, 6 insertions(+)
+ create mode 100644 mypy.ini
+
+diff --git a/mypy.ini b/mypy.ini
+new file mode 100644
+index 0000000..1cd3b58
+--- /dev/null
++++ b/mypy.ini
+@@ -0,0 +1,6 @@
++[mypy]
++incremental = true
++strict = true
++
++[mypy-immutables.map,immutables._testutils]
++ignore_errors = true
diff --git a/debian/patches/0002-ensure-uniform-quoting-in-mypy-test-messages.patch b/debian/patches/0002-ensure-uniform-quoting-in-mypy-test-messages.patch
new file mode 100644
index 0000000..8bf5a5f
--- /dev/null
+++ b/debian/patches/0002-ensure-uniform-quoting-in-mypy-test-messages.patch
@@ -0,0 +1,20 @@
+From: Wojtek Kosior <koszko@koszko.org>
+Date: Sat, 9 Jul 2022 08:12:18 +0200
+Subject: ensure uniform quoting in mypy test messages
+
+---
+ tests/test_mypy.py | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/tests/test_mypy.py b/tests/test_mypy.py
+index fcdc11c..12f19b3 100644
+--- a/tests/test_mypy.py
++++ b/tests/test_mypy.py
+@@ -14,6 +14,7 @@ else:
+ # and at no other time.
+ def renormalize_error_messages(messages):
+ messages = [x for x in messages if not x.endswith(' defined here')]
++ messages = [x.replace('\'', '"') for x in messages]
+ return normalize_error_messages(messages)
+
+ mypy.test.testcmdline.normalize_error_messages = renormalize_error_messages
diff --git a/debian/patches/0003-remove-asterisks-used-to-mark-inferred-types-under-c.patch b/debian/patches/0003-remove-asterisks-used-to-mark-inferred-types-under-c.patch
new file mode 100644
index 0000000..864b611
--- /dev/null
+++ b/debian/patches/0003-remove-asterisks-used-to-mark-inferred-types-under-c.patch
@@ -0,0 +1,19 @@
+From: Wojtek Kosior <koszko@koszko.org>
+Date: Sat, 9 Jul 2022 08:52:14 +0200
+Subject: remove asterisks used to mark inferred types under certain mypy
+ versions
+
+---
+ tests/test-data/check-immu.test | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/test-data/check-immu.test b/tests/test-data/check-immu.test
+index 4998542..2ee32f1 100644
+--- a/tests/test-data/check-immu.test
++++ b/tests/test-data/check-immu.test
+@@ -70,4 +70,4 @@ def mutate() -> None:
+ mm.set('3', '4')
+ m2 = mm.finish()
+
+- reveal_type(m2) # N: Revealed type is "immutables._map.Map[builtins.str*, builtins.str*]"
++ reveal_type(m2) # N: Revealed type is "immutables._map.Map[builtins.str, builtins.str]"
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..5874beb
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,3 @@
+0001-add-mypy.ini-for-older-mypy-versions-that-don-t-supp.patch
+0002-ensure-uniform-quoting-in-mypy-test-messages.patch
+0003-remove-asterisks-used-to-mark-inferred-types-under-c.patch