aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am29
1 files changed, 24 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 5834e07..c8975ca 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,28 @@
+## C program
SUBDIRS = src
-dist_doc_DATA = README.txt
+# data files
+dist_doc_DATA = README.txt copyright
+EXTRA_DIST = examples licenses
+
+install_doc: $(srcdir)/examples $(srcdir)/licenses
+ cd $(srcdir) && for D in `find examples licenses -type d`; do \
+ $(MKDIR_P) $(DESTDIR)/$(docdir)/"$$D"; \
+ done
+ cd $(srcdir) && for F in `find examples licenses -type f`; do \
+ $(INSTALL_DATA) "$$F" $(DESTDIR)/$(docdir)/"$$F"; \
+ done
+
+uninstall_doc:
+ rm -rf $(DESTDIR)/$(docdir)/examples $(DESTDIR)/$(docdir)/licenses
+ -rmdir $(DESTDIR)/$(docdir)
+
+install-data-local: install_doc
+uninstall-local: uninstall_doc
+
+.PHONY: install-doc uninstall-doc
+
+## init scripts
transform_name = @program_transform_name@
hydrilla_new_name = `echo hydrilla | sed '$(transform_name)'`
subst_perform = sed -e 's|[@]hydrilla[@]|'$(hydrilla_new_name)'|g' \
@@ -8,10 +30,8 @@ subst_perform = sed -e 's|[@]hydrilla[@]|'$(hydrilla_new_name)'|g' \
-e 's|[@]runstatedir[@]|$(runstatedir)|g' \
-e 's|[@]logdir[@]|$(localstatedir)/log|g'
-
bin_SCRIPTS =
CLEANFILES =
-EXTRA_DIST =
# SysV init script
CLEANFILES += daemon/sysv
@@ -28,9 +48,8 @@ install-sysv-script: $(srcdir)/daemon/sysv
$(INSTALL_SCRIPT) $< $(sysv_script_dest_path)
uninstall-sysv-script:
- rm -f $(DESTDIR)/$(sysv_script_dest_path)
+ rm -f $(sysv_script_dest_path)
-# Inform Automake about our special (un)install rules
install-exec-local: install-sysv-script
uninstall-local: uninstall-sysv-script