aboutsummaryrefslogtreecommitdiff
path: root/src/hydrilla.builder.egg-info
diff options
context:
space:
mode:
authorWojtek Kosior <koszko@koszko.org>2022-06-15 11:09:58 +0200
committerWojtek Kosior <koszko@koszko.org>2022-06-15 11:09:58 +0200
commit22c722bf59e59246f47491c7229b17f9ef783614 (patch)
treebdcfbfae93f5e54d9b2b39465945419406b5e96a /src/hydrilla.builder.egg-info
parent6bc04f8097e44e55cbf543d811ccd90671faedbc (diff)
downloadhydrilla-builder-debian-upstream.tar.gz
hydrilla-builder-debian-upstream.zip
New upstream version 1.1~beta1upstream/1.1_beta1debian-upstream
Diffstat (limited to 'src/hydrilla.builder.egg-info')
-rw-r--r--src/hydrilla.builder.egg-info/PKG-INFO13
-rw-r--r--src/hydrilla.builder.egg-info/SOURCES.txt45
-rw-r--r--src/hydrilla.builder.egg-info/requires.txt4
3 files changed, 44 insertions, 18 deletions
diff --git a/src/hydrilla.builder.egg-info/PKG-INFO b/src/hydrilla.builder.egg-info/PKG-INFO
index 7724a25..8ec8222 100644
--- a/src/hydrilla.builder.egg-info/PKG-INFO
+++ b/src/hydrilla.builder.egg-info/PKG-INFO
@@ -1,6 +1,6 @@
Metadata-Version: 2.1
Name: hydrilla.builder
-Version: 1.0
+Version: 1.1b1
Summary: Hydrilla package builder
Home-page: https://git.koszko.org/hydrilla-builder
Author: Wojtek Kosior
@@ -24,19 +24,19 @@ Description: # Hydrilla builder
### Build
+ * build (a PEP517 package builder)
* setuptools
* wheel
* setuptools_scm
- * babel
+ * babel (Python library)
### Test
* pytest
- * reuse
- ## Building & testing
+ ## Building & testing & installation from wheel
- Build and test processed are analogous to those described in the [README of Hydrilla server part](https://git.koszko.org/pydrilla/about).
+ Build, test and installation processes are analogous to those described in the [README of Hydrilla server part](https://git.koszko.org/pydrilla/about).
## Running
@@ -50,6 +50,8 @@ Description: # Hydrilla builder
```
You might as well like to run from sources, without installation:
+
+ ``` shell
mkdir /tmp/bananowarzez/
./setup.py compile_catalog # generate the necessary .po files
PYTHONPATH=src python3 -m hydrilla.builder -s src/test/source-package-example/ \
@@ -86,4 +88,5 @@ Classifier: Topic :: Software Development :: Build Tools
Requires-Python: >=3.7
Description-Content-Type: text/markdown
Provides-Extra: setup
+Provides-Extra: spdx
Provides-Extra: test
diff --git a/src/hydrilla.builder.egg-info/SOURCES.txt b/src/hydrilla.builder.egg-info/SOURCES.txt
index de24145..a821b99 100644
--- a/src/hydrilla.builder.egg-info/SOURCES.txt
+++ b/src/hydrilla.builder.egg-info/SOURCES.txt
@@ -1,6 +1,7 @@
MANIFEST.in
README.md
README.md.license
+conftest.py
pyproject.toml
setup.cfg
setup.py
@@ -21,22 +22,40 @@ src/hydrilla/builder/__init__.py
src/hydrilla/builder/__main__.py
src/hydrilla/builder/_version.py
src/hydrilla/builder/build.py
+src/hydrilla/builder/common_errors.py
+src/hydrilla/builder/local_apt.py
+src/hydrilla/builder/piggybacking.py
src/hydrilla/builder/locales/en_US/LC_MESSAGES/hydrilla-messages.po
-src/hydrilla/schemas/api_mapping_description-1.0.1.schema.json
-src/hydrilla/schemas/api_mapping_description-1.0.1.schema.json.license
-src/hydrilla/schemas/api_query_result-1.0.1.schema.json
-src/hydrilla/schemas/api_query_result-1.0.1.schema.json.license
-src/hydrilla/schemas/api_resource_description-1.0.1.schema.json
-src/hydrilla/schemas/api_resource_description-1.0.1.schema.json.license
-src/hydrilla/schemas/api_source_description-1.0.1.schema.json
-src/hydrilla/schemas/api_source_description-1.0.1.schema.json.license
-src/hydrilla/schemas/common_definitions-1.0.1.schema.json
-src/hydrilla/schemas/common_definitions-1.0.1.schema.json.license
-src/hydrilla/schemas/package_source-1.0.1.schema.json
-src/hydrilla/schemas/package_source-1.0.1.schema.json.license
+src/hydrilla/schemas/1.x/api_mapping_description-1.0.1.schema.json
+src/hydrilla/schemas/1.x/api_mapping_description-1.0.1.schema.json.license
+src/hydrilla/schemas/1.x/api_query_result-1.0.1.schema.json
+src/hydrilla/schemas/1.x/api_query_result-1.0.1.schema.json.license
+src/hydrilla/schemas/1.x/api_resource_description-1.0.1.schema.json
+src/hydrilla/schemas/1.x/api_resource_description-1.0.1.schema.json.license
+src/hydrilla/schemas/1.x/api_source_description-1.0.1.schema.json
+src/hydrilla/schemas/1.x/api_source_description-1.0.1.schema.json.license
+src/hydrilla/schemas/1.x/common_definitions-1.0.1.schema.json
+src/hydrilla/schemas/1.x/common_definitions-1.0.1.schema.json.license
+src/hydrilla/schemas/1.x/package_source-1.0.1.schema.json
+src/hydrilla/schemas/1.x/package_source-1.0.1.schema.json.license
+src/hydrilla/schemas/2.x/api_mapping_description-2.schema.json
+src/hydrilla/schemas/2.x/api_mapping_description-2.schema.json.license
+src/hydrilla/schemas/2.x/api_query_result-2.schema.json
+src/hydrilla/schemas/2.x/api_query_result-2.schema.json.license
+src/hydrilla/schemas/2.x/api_resource_description-2.schema.json
+src/hydrilla/schemas/2.x/api_resource_description-2.schema.json.license
+src/hydrilla/schemas/2.x/api_source_description-2.schema.json
+src/hydrilla/schemas/2.x/api_source_description-2.schema.json.license
+src/hydrilla/schemas/2.x/common_definitions-2.schema.json
+src/hydrilla/schemas/2.x/common_definitions-2.schema.json.license
+src/hydrilla/schemas/2.x/package_source-2.schema.json
+src/hydrilla/schemas/2.x/package_source-2.schema.json.license
src/hydrilla/util/__init__.py
src/hydrilla/util/_util.py
-tests/test_hydrilla_builder.py
+tests/__init__.py
+tests/helpers.py
+tests/test_build.py
+tests/test_local_apt.py
tests/source-package-example/README.txt
tests/source-package-example/README.txt.license
tests/source-package-example/bye.js
diff --git a/src/hydrilla.builder.egg-info/requires.txt b/src/hydrilla.builder.egg-info/requires.txt
index 4a40137..103a88b 100644
--- a/src/hydrilla.builder.egg-info/requires.txt
+++ b/src/hydrilla.builder.egg-info/requires.txt
@@ -2,7 +2,11 @@ click
jsonschema>=3.0
[setup]
+babel
setuptools_scm
+[spdx]
+reuse
+
[test]
pytest