diff options
author | Wojtek Kosior <koszko@koszko.org> | 2022-02-11 16:51:44 +0100 |
---|---|---|
committer | Wojtek Kosior <koszko@koszko.org> | 2022-02-12 11:34:59 +0100 |
commit | 9e71d383bf59573a1dd48964a2c7900a57161973 (patch) | |
tree | 8d4f2013815836ae4665825809b1f3bf8e9c4b77 /setup.py | |
parent | 4e46d7f7446b66e7f128169bb15b9cc88b03b3ba (diff) | |
download | hydrilla-builder-9e71d383bf59573a1dd48964a2c7900a57161973.tar.gz hydrilla-builder-9e71d383bf59573a1dd48964a2c7900a57161973.zip |
internationalize using Babel
this commit also makes the sdist tarball generated by setuptools REUSE-compliant
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 12 |
1 files changed, 11 insertions, 1 deletions
@@ -7,4 +7,14 @@ import setuptools -setuptools.setup() +from setuptools.command.build_py import build_py + +class CustomBuildCommand(build_py): + ''' + The build command but runs babel before build. + ''' + def run(self, *args, **kwargs): + self.run_command('compile_catalog') + super().run(*args, **kwargs) + +setuptools.setup(cmdclass={'build_py': CustomBuildCommand}) |