aboutsummaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorWojtek Kosior <koszko@koszko.org>2022-04-22 15:32:59 +0200
committerWojtek Kosior <koszko@koszko.org>2022-04-22 15:58:51 +0200
commitfbb397727868d676c8e6591ab07f02e97fa09118 (patch)
tree1423b5245db6e87a5abd257c8a251c4bc743cbc9 /pyproject.toml
parentf08583aa2a144b111c5ba17570f904109a41cbfc (diff)
downloadhydrilla-builder-fbb397727868d676c8e6591ab07f02e97fa09118.tar.gz
hydrilla-builder-fbb397727868d676c8e6591ab07f02e97fa09118.zip
use pyproject.toml for pytest configuration and move all tests to tests/ directory
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml7
1 files changed, 7 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index cffd3dd..a428c52 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -10,3 +10,10 @@ requires = ["setuptools>=45", "wheel", "setuptools_scm>=5.0", "babel"]
[tool.setuptools_scm]
write_to = "src/hydrilla/builder/_version.py"
+
+[tool.pytest.ini_options]
+minversion = "6.0"
+addopts = "-ra -q"
+testpaths = [
+ "tests"
+]